aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2019-11-19 22:02:31 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-25 07:27:31 +0000
commit0af557e86d000ac9a1bc35a99b5d14d417c67d72 (patch)
tree10ef1dea84e15303e405038f65a72914068318e3
parentdab61cbcc990395fe0bdc5df3719aa6946d37eeb (diff)
downloadaports-0af557e86d000ac9a1bc35a99b5d14d417c67d72.tar.bz2
aports-0af557e86d000ac9a1bc35a99b5d14d417c67d72.tar.xz
main/dbus: Remove uuid generation from post-install
In the past, dbus uuid generation was done as a post install step. Years later, this was copied/moved into the start-up script. This makes a lot of sense, where in the post-install step it does not. More importantly however, when bootstrapping alpine into a directory, with the dbus package, dbus-uuidgen fails during the post-install phase due to missing /dev/urandom, which is expected not to exist in a alternative root, as can be seen in the following error Failed to generate UUID: Could not open /dev/urandom: No such file or directory ERROR: dbus-1.12.16-r0.post-install: script exited with error 1 Lets drop this line all together as it serves no purpose with the UUID being generated at startup anyway. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
-rw-r--r--main/dbus/APKBUILD4
-rw-r--r--main/dbus/dbus.post-install3
2 files changed, 2 insertions, 5 deletions
diff --git a/main/dbus/APKBUILD b/main/dbus/APKBUILD
index 57a1f7d82d..d0f5d58aeb 100644
--- a/main/dbus/APKBUILD
+++ b/main/dbus/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dbus
pkgver=1.12.16
-pkgrel=1
+pkgrel=2
pkgdesc="Freedesktop.org message bus system"
options="!check" # Introduces circular dependency with xorg-server (xvfb-run -> xvfb)
url="https://www.freedesktop.org/Software/dbus"
@@ -14,7 +14,7 @@ depends_dev="util-linux-dev"
makedepends="$depends_dev expat-dev libx11-dev autoconf automake libtool xmlto
libsm-dev glib-dev"
checkdepends="xvfb-run"
-install="$pkgname.pre-install $pkgname.post-install"
+install="$pkgname.pre-install"
source="https://dbus.freedesktop.org/releases/dbus/dbus-$pkgver.tar.gz
$pkgname.initd
"
diff --git a/main/dbus/dbus.post-install b/main/dbus/dbus.post-install
deleted file mode 100644
index 1120ec2048..0000000000
--- a/main/dbus/dbus.post-install
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-exec dbus-uuidgen --ensure=/etc/machine-id