aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-16 18:52:55 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-16 19:21:08 -0300
commit2a0ad40bbce46de82b5885bfd6b9357eba8f7a81 (patch)
tree08426c960900bb6d34b4f8f14304560d279e761c
parent101d28fa4e4a8199dfcbf5fe4fc9190eec39b6f2 (diff)
downloadaports-2a0ad40bbce46de82b5885bfd6b9357eba8f7a81.tar.bz2
aports-2a0ad40bbce46de82b5885bfd6b9357eba8f7a81.tar.xz
community/spirv-headers: use git version to fix spirv-tools build
-rw-r--r--community/spirv-headers/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/community/spirv-headers/APKBUILD b/community/spirv-headers/APKBUILD
index 121cd63f9f..ee3e315c53 100644
--- a/community/spirv-headers/APKBUILD
+++ b/community/spirv-headers/APKBUILD
@@ -3,16 +3,17 @@
pkgname=spirv-headers
_pkgname=SPIRV-Headers
pkgver=1.4.1
-pkgrel=0
+pkgrel=1
pkgdesc="Machine-readable files for the SPIR-V Registry"
options="!check" # No testsuite
url="https://github.com/KhronosGroup/SPIRV-Headers"
arch="noarch"
license="GPL-3.0-or-later"
makedepends="cmake"
-source="$pkgname-$pkgver.tar.gz::https://github.com/KhronosGroup/$_pkgname/archive/${pkgver}.tar.gz"
+_commit=e4322e3be589e1ddd44afb20ea842a977c1319b8
+source="$pkgname-$_commit.tar.gz::https://github.com/KhronosGroup/$_pkgname/archive/$_commit.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+builddir="$srcdir/$_pkgname-$_commit"
build() {
cmake \
@@ -27,4 +28,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="def34baa2a67128126d0918445b757e2b67a5cf012f6ca4f9a671741e4b1bf6939a7ebd114f7741bcd19bd6c22d0c5dc46adc8ac62ec474164278858c2e65dcf spirv-headers-1.4.1.tar.gz"
+sha512sums="c63a771b5d0de871d76f85cdf18cda6f506eb24d6a8d9117d7a81456e222625ba15ae56f5bde6cc63fdb2d64d6270b2640616d1511cef1ab4a3798f14aa53cb0 spirv-headers-e4322e3be589e1ddd44afb20ea842a977c1319b8.tar.gz"