aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-07 18:26:38 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-07 18:41:29 +0200
commit30b8ce58306e9e1c384a77477e9ee4bcf21ff7e6 (patch)
tree3f8a2bc78084b1536f76571109c173c596ac8abc
parentc5476139ab838bbaea8b7a1ca8ef24650ebc608b (diff)
downloadaports-30b8ce58306e9e1c384a77477e9ee4bcf21ff7e6.tar.bz2
aports-30b8ce58306e9e1c384a77477e9ee4bcf21ff7e6.tar.xz
testing/ocaml-react: upgrade to 1.2.1
-rw-r--r--testing/ocaml-react/APKBUILD31
-rw-r--r--testing/ocaml-react/fix-safe-string.patch18
2 files changed, 14 insertions, 35 deletions
diff --git a/testing/ocaml-react/APKBUILD b/testing/ocaml-react/APKBUILD
index dd9d0dae16..08b731cea3 100644
--- a/testing/ocaml-react/APKBUILD
+++ b/testing/ocaml-react/APKBUILD
@@ -2,34 +2,29 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ocaml-react
_pkgname=react
-pkgver=1.2.0
-pkgrel=1
+pkgver=1.2.1
+pkgrel=0
pkgdesc="OCaml framework for Functional Reactive Programming (FRP)"
url="http://erratique.ch/software/react"
arch="all !x86 !armhf !s390x" # limited by ocaml aport
license="ISC"
depends="ocaml-runtime"
-makedepends="ncurses ocaml ocaml-compiler-libs ocaml-findlib ocamlbuild opam"
+makedepends="ncurses ocaml ocaml-compiler-libs ocaml-findlib ocaml-topkg ocamlbuild opam"
options="textrels" # needed for ppc64le
-subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/dbuenzli/$_pkgname/archive/v$pkgver.tar.gz
- fix-safe-string.patch"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/dbuenzli/$_pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
- ocaml pkg/build.ml \
- native=true \
- native-dynlink=true
-
- ocamlbuild -use-ocamlfind test/tests.otarget
+ ocaml pkg/pkg.ml build --tests true
}
check() {
cd "$builddir"
- ./_build/test/test.native
+ ocaml pkg/pkg.ml test
}
package() {
@@ -38,11 +33,14 @@ package() {
opam-installer -i \
--prefix="$pkgdir/usr" \
--libdir="$pkgdir/$(ocamlc -where)" \
- --docdir="$pkgdir/usr/share/doc/$pkgname" \
$_pkgname.install
- # Remove annotation files.
- rm -Rf "$pkgdir"/usr/lib/ocaml/$_pkgname/*.cmt*
+ # There's just a readme and changelog.
+ rm -Rf "$pkgdir"/usr/doc
+
+ # Remove annotation files and sources.
+ cd "$pkgdir"/usr/lib/ocaml/$_pkgname
+ rm -f *.cmt* *.ml
}
dev() {
@@ -56,5 +54,4 @@ dev() {
mv *.cmx *.cmxa *.mli "$subpkgdir"/$sitelib/
}
-sha512sums="929f0a5e84d6e92c366e3c43c582c48e639eab662f654ff65b4789155e96ce4bdd10c38acfb932a20ddce4042943baa2644934be4d7542a20b801203437c3d21 ocaml-react-1.2.0.tar.gz
-8ac6aa6f703ab866abcae0640f539a9eb0f2796713306191d308f6988b186514dd3a5b70197a56ef6f83d62d5d179d2210241e001b8a944f5272757326e978fc fix-safe-string.patch"
+sha512sums="e760c4504519744b66655be113676cb6e3f016fc8a5c59dca063365223d5d5efc66be3ff2b7a2ad3a745975d1b0aaf37634af699d1a706d3bf3b37c1671e81e3 ocaml-react-1.2.1.tar.gz"
diff --git a/testing/ocaml-react/fix-safe-string.patch b/testing/ocaml-react/fix-safe-string.patch
deleted file mode 100644
index 5a9ee3e2a5..0000000000
--- a/testing/ocaml-react/fix-safe-string.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Fix for compatibility with ocaml >=4.06
-
-Patch-Source: https://src.fedoraproject.org/rpms/ocaml-react/blob/f28/f/react-1.2.0-safe-string-fix.patch
-
---- a/test/breakout.ml
-+++ b/test/breakout.ml
-@@ -136,9 +136,9 @@
- let time, send_time = E.create ()
- let key, send_key = E.create ()
- let gather () = (* updates primitive events. *)
-- let c = " " in
-+ let c = Bytes.of_string " " in
- let i = Unix.stdin in
-- let input_char i = ignore (Unix.read i c 0 1); c.[0] in
-+ let input_char i = ignore (Unix.read i c 0 1); Bytes.get c 0 in
- let dt = 0.1 in
- while true do
- if Unix.select [i] [] [] dt = ([i], [], []) then send_key (input_char i);