aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2019-02-08 10:05:53 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-08 10:05:53 +0000
commit518353142d93a2037ce2ea3b7395e04066bd26bf (patch)
treed3563feef42c8cb51f798d3a7858a89321d0448d
parentf9633c1c241950cae0a21cf515d6f849a3b79b4f (diff)
downloadaports-518353142d93a2037ce2ea3b7395e04066bd26bf.tar.bz2
aports-518353142d93a2037ce2ea3b7395e04066bd26bf.tar.xz
Revert "testing/tup: new aport"
-rw-r--r--testing/tup/APKBUILD62
1 files changed, 0 insertions, 62 deletions
diff --git a/testing/tup/APKBUILD b/testing/tup/APKBUILD
deleted file mode 100644
index cb293afbfb..0000000000
--- a/testing/tup/APKBUILD
+++ /dev/null
@@ -1,62 +0,0 @@
-# Contributor:
-# Maintainer:
-pkgname="tup"
-pkgver="0.7.8"
-pkgrel=0
-pkgdesc="Tup is a file-based build system."
-url="http://gittup.org/tup/"
-arch="all"
-license="GPL-2.0-only"
-depends=""
-checkdepends="bash ccache clang coreutils findutils sqlite"
-makedepends="fuse-dev pcre-dev pkgconf-dev sqlite-dev"
-install=""
-subpackages="$pkgname-doc"
-source="http://gittup.org/tup/releases/$pkgname-v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-v$pkgver"
-
-build() {
- cd "$builddir"
-
- # Eliminate `git describe` from link.sh
- sed -i.orig -e '/^version=/s/=.*/="v'"$pkgver"'"/' src/tup/link.sh
-
- # Use the system sqlite3
- echo >>tup.config 'CONFIG_TUP_USE_SYSTEM_SQLITE=y'
-
- /bin/sh -e bootstrap.sh
-}
-
-check() {
- cd "$builddir/test"
-
- rm -f t4047-open-fds.sh # Just a terribly written test.
-
- echo 'Beginning tests (output to file)'
-
- # This is a lot of output we don't normally care about.
- # When an error occurs, we will care so output it then.
- ./test.sh > .test-output 2>&1 || {
- rc=$?
- sync
- sleep 1
- cat .test-output
- return $rc
- }
-}
-
-package() {
- cd "$builddir"
-
- install -m 0755 -d "$pkgdir" \
- "$pkgdir/usr" "$pkgdir/usr/bin" "$pkgdir/usr/share" \
- "$pkgdir/usr/share/man" "$pkgdir/usr/share/man/man1"
-
- install -m 0755 -o root -g root -p -D \
- -t "$pkgdir/usr/bin/" "$pkgname"
-
- install -m 0644 -o root -g root -p -D \
- -t "$pkgdir/usr/share/man/man1/" "$pkgname.1"
-}
-
-sha512sums="8b0e5cdfd233b7d58abdc2a761f04434fd3665547120a78a410818ccbc5ce7ad267214bc860b5d323c14697bb50af47bf69cf937ae84367e16a10607c7cbdd63 tup-v0.7.8.tar.gz"