aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornick black <dankamongmen@gmail.com>2019-01-27 02:47:35 -0500
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-06 07:58:35 +0000
commit52ceac8c425a851702ebdb00885e3e1a2ff8cbc3 (patch)
tree84315c1389671ad444e16c099d176caa5336227a
parent6508ca67e206bd8c4b5fcd0fbb334418ba3ba08d (diff)
downloadaports-52ceac8c425a851702ebdb00885e3e1a2ff8cbc3.tar.bz2
aports-52ceac8c425a851702ebdb00885e3e1a2ff8cbc3.tar.xz
testing/capnproto: new aport
Cap'n Proto serialization and RPC library and tools v0.7.0. Generates two packages: capnproto and capnproto-dev. The latter includes schema compilers, along with headers and linkables. The upstream test suite is run via check(). Built against Edge. Alpha-level TLS RPC support is not built, following Debian's lead.
-rw-r--r--testing/capnproto/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/capnproto/APKBUILD b/testing/capnproto/APKBUILD
new file mode 100644
index 0000000000..8bf3948a88
--- /dev/null
+++ b/testing/capnproto/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Nick Black <dankamongmen@gmail.com>
+# Maintainer:
+pkgname=capnproto
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Tools for working with the Cap'n Proto format"
+url="https://capnproto.org/"
+arch="all"
+license="MIT"
+depends=
+makedepends="linux-headers"
+subpackages="$pkgname-dev"
+source="https://capnproto.org/$pkgname-c++-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-c++-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr/ --without-openssl
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+# We want to move the schema compilers into the dev package.
+# See https://wiki.alpinelinux.org/wiki/APKBUILD_Reference#dev.28.29
+dev() {
+ default_dev
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/* "$subpkgdir"/usr/bin
+}
+
+sha512sums="9f8fb5753155798fcf9377a87f984a54d9fc5157c41aa11cd94108a773ca22d6e6952657e2d8079c9806f7de06f316c94957329fa52dbab6207aaa3b52348f04 capnproto-c++-0.7.0.tar.gz"