aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-11-22 20:23:00 +0100
committerMilan P. Stanić <mps@arvanta.net>2019-11-22 20:26:53 +0100
commit700a08bcaac015c279272adfb4f0fe7b5a2383ee (patch)
treec08b2e233fe54cdb5d81105b7df3e7af76b64727
parent7db8f0b9ad5fa68580d210dc08426c4c8cf3f4c2 (diff)
downloadaports-700a08bcaac015c279272adfb4f0fe7b5a2383ee.tar.bz2
aports-700a08bcaac015c279272adfb4f0fe7b5a2383ee.tar.xz
testing/vboot-utils: fix static build
install devkeys remove prepare() function modernize
-rw-r--r--testing/vboot-utils/0001-Remove-static-futility.patch38
-rw-r--r--testing/vboot-utils/APKBUILD20
-rw-r--r--testing/vboot-utils/no-static.patch38
3 files changed, 45 insertions, 51 deletions
diff --git a/testing/vboot-utils/0001-Remove-static-futility.patch b/testing/vboot-utils/0001-Remove-static-futility.patch
deleted file mode 100644
index cae6b3a847..0000000000
--- a/testing/vboot-utils/0001-Remove-static-futility.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 59166c9aacda115ea2feb2e3f6a01c23f5e91fc2 Mon Sep 17 00:00:00 2001
-From: Kevin Mihelich <kevin@archlinuxarm.org>
-Date: Sun, 18 Mar 2018 14:46:01 -0600
-Subject: [PATCH] Remove static futility
-
----
- Makefile | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 1f3e7f664..75168b146 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1112,7 +1112,7 @@ signing_install: ${SIGNING_SCRIPTS} ${SIGNING_SCRIPTS_DEV} ${SIGNING_COMMON}
- # new Firmware Utility
-
- .PHONY: futil
--futil: ${FUTIL_STATIC_BIN} ${FUTIL_BIN}
-+futil: ${FUTIL_BIN}
-
- ${FUTIL_STATIC_BIN}: LDLIBS += ${CRYPTO_STATIC_LIBS} -lpthread
- ${FUTIL_STATIC_BIN}: ${FUTIL_STATIC_OBJS} ${UTILLIB}
-@@ -1125,10 +1125,10 @@ ${FUTIL_BIN}: ${FUTIL_OBJS} ${UTILLIB} ${FWLIB20} ${UTILBDB}
- ${Q}${LD} -o $@ ${CFLAGS} ${LDFLAGS} $^ ${LDLIBS}
-
- .PHONY: futil_install
--futil_install: ${FUTIL_BIN} ${FUTIL_STATIC_BIN}
-+futil_install: ${FUTIL_BIN}
- @${PRINTF} " INSTALL futility\n"
- ${Q}mkdir -p ${UB_DIR}
-- ${Q}${INSTALL} -t ${UB_DIR} ${FUTIL_BIN} ${FUTIL_STATIC_BIN}
-+ ${Q}${INSTALL} -t ${UB_DIR} ${FUTIL_BIN}
- ${Q}for prog in ${FUTIL_SYMLINKS}; do \
- ln -sf futility "${UB_DIR}/$$prog"; done
-
---
-2.16.2
-
diff --git a/testing/vboot-utils/APKBUILD b/testing/vboot-utils/APKBUILD
index 797d603532..f8b84b6486 100644
--- a/testing/vboot-utils/APKBUILD
+++ b/testing/vboot-utils/APKBUILD
@@ -2,36 +2,30 @@
# Maintainer: Milan P. Stanić <mps@arvanta.net>
pkgname=vboot-utils
pkgver=6310032
-pkgrel=0
+pkgrel=1
pkgdesc="Chromium OS vboot utilities"
url="https://github.com/coreboot/vboot"
arch="all !ppc64le !s390x"
license="custom:chromiumos"
+options="!check" # test fails but package works
makedepends="yaml-dev xz-dev fts-dev openssl-dev util-linux-dev bash linux-headers"
subpackages="cgpt $pkgname-doc"
source="http://cdn-fastly.deb.debian.org/debian/pool/main/v/vboot-utils/vboot-utils_0~R63-10032.B.orig.tar.gz
- 0001-Remove-static-futility.patch"
+ no-static.patch
+ "
builddir="$srcdir"
-prepare() {
- sed -i 's/-Werror//g' Makefile
-}
-
build() {
- cd "$builddir"
case "$CARCH" in
arm*|aarch64) ARCH=arm make V=1 ;;
esac
make V=1
}
-check() {
- cd "$builddir"
-}
-
package() {
- cd "$builddir"
make DESTDIR="$pkgdir"/usr install
+ install -d "$pkgdir"/usr/share/vboot/
+ cp -r tests/devkeys "$pkgdir"/usr/share/vboot/devkeys
mkdir -p "$pkgdir"/usr/share/doc
cp LICENSE "$pkgdir"/usr/share/doc
}
@@ -42,4 +36,4 @@ cgpt() {
mv "$pkgdir"/usr/bin/cgpt "$subpkgdir"/usr/sbin/
}
sha512sums="48c0cf858f74cbb0020212ac619ed93ac011530e4f25518e05301f710bb78eba532ee901e79a04d6808122ef589fdf4c6a0f53656350d2f9bf717c588fc795fc vboot-utils_0~R63-10032.B.orig.tar.gz
-baaa5c262352d76542cd1012fa66ce75a1251430181cf0063316a3a632dc248539a619ebd4d5da546281170dd944f256682502399cc6b367057c2167a486bebf 0001-Remove-static-futility.patch"
+64c5e219ea247b1d81a7e8d10ee99fe2d008ee8579bcc41734861a808b9b2c35f889b0732223b85e87052caa712408894b5364f675e1d22fba63a697b27193d3 no-static.patch"
diff --git a/testing/vboot-utils/no-static.patch b/testing/vboot-utils/no-static.patch
new file mode 100644
index 0000000000..0dd36a92bf
--- /dev/null
+++ b/testing/vboot-utils/no-static.patch
@@ -0,0 +1,38 @@
+--- a/Makefile 2017-10-23 18:59:44.000000000 +0200
++++ b/Makefile 2019-11-22 18:54:48.089235572 +0100
+@@ -134,7 +134,7 @@
+ #
+ # Flag ordering: arch, then -f, then -m, then -W
+ DEBUG_FLAGS := $(if ${DEBUG},-g -O0,-Os)
+-WERROR := -Werror
++WERROR :=
+ COMMON_FLAGS := -nostdinc -pipe \
+ -ffreestanding -fno-builtin -fno-stack-protector \
+ ${WERROR} -Wall -Wstrict-prototypes ${DEBUG_FLAGS}
+@@ -648,7 +648,7 @@
+ # The unified firmware utility will eventually replace all the others
+ FUTIL_BIN = ${BUILD}/futility/futility
+ # But we still need both static (tiny) and dynamic (with openssl) versions.
+-FUTIL_STATIC_BIN = ${FUTIL_BIN}_s
++#FUTIL_STATIC_BIN = ${FUTIL_BIN}_s
+
+ # These are the executables that are now built in to futility. We'll create
+ # symlinks for these so the old names will still work.
+@@ -1004,7 +1004,7 @@
+ # Link tests for external repos
+ ${BUILD}/host/linktest/extern: ${HOSTLIB}
+ ${BUILD}/host/linktest/extern: LIBS = ${HOSTLIB}
+-${BUILD}/host/linktest/extern: LDLIBS += -static
++#${BUILD}/host/linktest/extern: LDLIBS += -static
+ TEST_OBJS += ${BUILD}/host/linktest/extern.o
+
+ .PHONY: hostlib
+@@ -1096,7 +1096,7 @@
+ ${UTIL_BINS} ${UTIL_BINS_STATIC}: LIBS = ${UTILLIB}
+
+ # Utilities for auto-update toolkits must be statically linked.
+-${UTIL_BINS_STATIC}: LDFLAGS += -static
++#${UTIL_BINS_STATIC}: LDFLAGS += -static
+
+
+ .PHONY: utils