aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-24 13:54:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-24 15:23:25 +0000
commit76de376c496f8534f8741e025a1f76d936a6e11f (patch)
tree74bb7af0da34c206c41cb26f6e537f258ff509ab
parentdeb2c1013b501182939180077b2ad948b3a383fb (diff)
downloadaports-76de376c496f8534f8741e025a1f76d936a6e11f.tar.bz2
aports-76de376c496f8534f8741e025a1f76d936a6e11f.tar.xz
testing/py3-dockerpty: new aport
Python library to use the pseudo-tty of a docker container https://github.com/d11wtq/dockerpty
-rw-r--r--testing/py3-dockerpty/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py3-dockerpty/APKBUILD b/testing/py3-dockerpty/APKBUILD
new file mode 100644
index 0000000000..d34783b7b5
--- /dev/null
+++ b/testing/py3-dockerpty/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=py3-dockerpty
+pkgver=0.4.1
+pkgrel=0
+pkgdesc="Python library to use the pseudo-tty of a docker container"
+url="https://github.com/d11wtq/dockerpty"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 docker-py"
+makedepends="python3-dev"
+source="https://pypi.io/packages/source/d/dockerpty/dockerpty-$pkgver.tar.gz"
+builddir="$srcdir/dockerpty-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="6afbc7ef5e352853b0d908ec047fe16e1fe513fae49ccc83142a77429f808b7e24201d47ebf83e21db4a05272308124516f9be5a57ed6c4e47e73837003562ea dockerpty-0.4.1.tar.gz"