aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorShiz <hi@shiz.me>2017-04-08 03:27:16 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-04-08 03:31:42 +0000
commit81202de05b40fe36925e0936b3be6e94227d0e90 (patch)
treec6dfc8b459a3ac9b4216242dce786f67e69d83fb
parentfa0fa3ef75a570c3f86cd44881b1f21edb2d33c3 (diff)
downloadaports-81202de05b40fe36925e0936b3be6e94227d0e90.tar.bz2
aports-81202de05b40fe36925e0936b3be6e94227d0e90.tar.xz
main/libunwind: enable C++ exception support
Some packages like Rust need the _Unwind_* symbols as part of libunwind. While the package configure.ac says this implementation doesn't work too well, other distros seem to have had it enabled for years without issues.
-rw-r--r--main/libunwind/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/main/libunwind/APKBUILD b/main/libunwind/APKBUILD
index 2df6cbd165..2baf41c0fb 100644
--- a/main/libunwind/APKBUILD
+++ b/main/libunwind/APKBUILD
@@ -3,7 +3,7 @@
pkgname=libunwind
pkgver=1.2
_pkgver=${pkgver/_/-}
-pkgrel=0
+pkgrel=1
pkgdesc="Portable and efficient C programming interface (API) to determine the call-chain of a program"
url="http://www.nongnu.org/libunwind/"
arch="x86_64 armhf aarch64"
@@ -34,6 +34,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
+ --enable-cxx-exceptions \
|| return 1
make || return 1
}