aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-05 03:03:57 -0300
committerFrancesco Colista <fcolista@alpinelinux.org>2019-06-05 06:35:18 +0000
commit8923e55df4fdf4f4e721ba7998b2d2f0c69eb914 (patch)
tree332b832fc2bdf38e8688b78daf9fb55d6fee2128
parent08599f63ab18c0fd7e500cc85ae962367f0722c8 (diff)
downloadaports-8923e55df4fdf4f4e721ba7998b2d2f0c69eb914.tar.bz2
aports-8923e55df4fdf4f4e721ba7998b2d2f0c69eb914.tar.xz
community/alpine: modernize, fix url, fix build
-rw-r--r--community/alpine/APKBUILD30
1 files changed, 9 insertions, 21 deletions
diff --git a/community/alpine/APKBUILD b/community/alpine/APKBUILD
index c9c23a3322..a16a849f66 100644
--- a/community/alpine/APKBUILD
+++ b/community/alpine/APKBUILD
@@ -3,36 +3,26 @@ pkgname=alpine
pkgver=2.21
_ver=${pkgver%_p*}
_pver=${pkgver##*_p}
-pkgrel=3
+pkgrel=4
pkgdesc="Text-based email client, friendly for novices but powerful"
-url="http://www.washington.edu/alpine/"
+url="http://alpine.x10host.com/alpine/"
arch="all"
license="Apache-2.0"
-depends=""
makedepends="openldap-dev heimdal-dev ncurses-dev openssl-dev
- automake autoconf libtool"
+ automake autoconf libtool gettext-dev"
subpackages="$pkgname-doc"
source="http://alpine.x10host.com/alpine/release/src/alpine-$pkgver.tar.xz
uclibc-musl.patch
"
-_builddir="$srcdir"/$pkgname-$_ver
+builddir="$srcdir"/$pkgname-$_ver
+
prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch)
- msg "Applying $i"
- patch -p1 -i "$srcdir"/$i || return 1
- ;;
- esac
- done
- libtoolize --force && aclocal -I m4 && autoconf \
- && automake --force --add-missing || return 1
+ default_prepare
+ autoreconf -fi
}
build() {
- cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -41,14 +31,12 @@ build() {
--without-tcl \
--disable-shared \
--with-system-pinerc=/etc/alpine.d/pine.conf \
- --with-system-fixed-pinerc=/etc/alpine.d/pine.conf.fixed \
- || return 1
+ --with-system-fixed-pinerc=/etc/alpine.d/pine.conf.fixed
make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
sha512sums="a2a36a033c8af79810816a7da7185c269808ba6d84d013691fd8b3764c63f5fb2284e6844ec5a5e99d168514ae636debf59fae962533a2916679e4e9109c6264 alpine-2.21.tar.xz