aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-05 22:51:46 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-30 15:02:04 +0000
commita38d1896efd321124a61b1d212cf79f9bbd352d8 (patch)
tree07ba9bd37ab8c3d557406c1eec9da4f0c6365b6e
parent108ff41757ae796c1c92ca6b2ccb61b58fb3d98e (diff)
downloadaports-a38d1896efd321124a61b1d212cf79f9bbd352d8.tar.bz2
aports-a38d1896efd321124a61b1d212cf79f9bbd352d8.tar.xz
community/vlc: rebuild for libdc1394
-rw-r--r--community/vlc/APKBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/community/vlc/APKBUILD b/community/vlc/APKBUILD
index 87a1c8561a..e5ccf59cf7 100644
--- a/community/vlc/APKBUILD
+++ b/community/vlc/APKBUILD
@@ -121,16 +121,13 @@ source="https://get.videolan.org/vlc/$pkgver/$pkgname-$pkgver.tar.xz
libvpx-1.8.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
-
prepare() {
default_prepare
- NOCONFIGURE=1 ./bootstrap
+ NOCONFIGURE=1 ./bootstrap
}
build() {
local _arch_opts=
- cd "$builddir"
export CFLAGS="$CFLAGS -D_GNU_SOURCE"
case "$CARCH" in
@@ -179,15 +176,13 @@ build() {
--enable-wma-fixed \
--enable-x264 \
--enable-xvideo \
- $_arch_opts \
- || return 1
+ $_arch_opts
- make || return 1
+ make
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
# delete cache as it's autocreated by trigger
rm -rf "$pkgdir"/usr/lib/vlc/plugins/plugins.dat
# delete unneeded mozilla and kde support files
@@ -196,7 +191,6 @@ package() {
}
check() {
- cd "$builddir"
make check
}
@@ -243,7 +237,7 @@ qt() {
cd "$pkgdir"
for i in $(find . -type f ); do
if ldd $i 2>/dev/null | grep -q "libQt"; then
- _mv "$i" || return 1
+ _mv "$i"
fi
done
mkdir -p "$subpkgdir"/usr/bin
@@ -260,7 +254,7 @@ xorg() {
cd "$pkgdir"
for i in $(find . -type f ); do
if ldd $i 2>/dev/null | grep -E -q "libX|x11|libxcb|libGL"; then
- echo $i | grep libavcodec_plugin.so || _mv "$i" || return 1
+ echo $i | grep libavcodec_plugin.so || _mv "$i"
fi
done
@@ -290,7 +284,7 @@ daemon() {
}
libs() {
- depends=
+ depends=""
mkdir -p "$subpkgdir"/usr/lib/vlc
mv "$pkgdir"/usr/lib/vlc/vlc-cache-gen \
"$subpkgdir"/usr/lib/vlc/
@@ -300,7 +294,7 @@ libs() {
_mv_plugins() {
local plugin=$1
pkgdesc="$pkgname $plugin plugin"
- depends=
+ depends=""
mkdir -p "$subpkgdir"/usr/lib/vlc/plugins
mv "$pkgdir"/usr/lib/vlc/plugins/"$plugin" \
"$subpkgdir"/usr/lib/vlc/plugins