aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-12-17 15:46:12 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-12-17 15:46:12 +0000
commitae7edd23775f55c6d20424294307c13a45a015ae (patch)
tree36172c28b96b5a59397aa111441362f9f355e8f2
parent187c30ab7cb5d4f2e87c159a0c8fd08ca972b0fd (diff)
downloadaports-ae7edd23775f55c6d20424294307c13a45a015ae.tar.bz2
aports-ae7edd23775f55c6d20424294307c13a45a015ae.tar.xz
main/lua-curl: fix build against curl 7.62
-rw-r--r--main/lua-curl/APKBUILD8
-rw-r--r--main/lua-curl/fix-build-with-curl-7.62.0.patch55
2 files changed, 60 insertions, 3 deletions
diff --git a/main/lua-curl/APKBUILD b/main/lua-curl/APKBUILD
index 4bc54b0d8b..0c823d8186 100644
--- a/main/lua-curl/APKBUILD
+++ b/main/lua-curl/APKBUILD
@@ -2,14 +2,15 @@
pkgname=lua-curl
_pkgname=Lua-cURLv3
pkgver=0.3.8
-pkgrel=0
+pkgrel=1
pkgdesc="Lua bindings to cURL library"
url="https://github.com/Lua-cURL/Lua-cURLv3"
arch="all"
license="MIT"
makedepends="curl-dev"
subpackages=""
-source="$pkgname-$pkgver.tar.gz::https://github.com/Lua-cURL/$_pkgname/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Lua-cURL/$_pkgname/archive/v$pkgver.tar.gz
+ fix-build-with-curl-7.62.0.patch"
builddir="$srcdir/$_pkgname-$pkgver"
_luaversions="5.1 5.2 5.3"
@@ -54,4 +55,5 @@ _subpackage() {
echo 'rock_manifest = {}' > "$rockdir"/rock_manifest
}
-sha512sums="38661c43f1d20f17b27375277c50050a64d0b76354d184a161b9ac73858d7cd83998711775e29c0a3d0a2cc3440fb96fe85c97579fec73b9bba0c83c8d5d5a6a lua-curl-0.3.8.tar.gz"
+sha512sums="38661c43f1d20f17b27375277c50050a64d0b76354d184a161b9ac73858d7cd83998711775e29c0a3d0a2cc3440fb96fe85c97579fec73b9bba0c83c8d5d5a6a lua-curl-0.3.8.tar.gz
+3cd33f93a782fffac2036e94fbadff7a668bd74af4f6301d6c917717cf842e6d2724497f9aece42f782f04ab9cc4d21b0f2e511a6bd636986735b6c3dbbae457 fix-build-with-curl-7.62.0.patch"
diff --git a/main/lua-curl/fix-build-with-curl-7.62.0.patch b/main/lua-curl/fix-build-with-curl-7.62.0.patch
new file mode 100644
index 0000000000..fbd129bdab
--- /dev/null
+++ b/main/lua-curl/fix-build-with-curl-7.62.0.patch
@@ -0,0 +1,55 @@
+Fix build with curl 7.62.0
+
+curl 7.62.0 deprecates the CURLE_SSL_CACERT error code, and unifies it
+with CURLE_PEER_FAILED_VERIFICATION. Adjust the errors list to match.
+
+This fixes the following build failure:
+
+src/lcerr_easy.h: In function 'lcurl_err_easy_mnemo':
+src/lcerror.c:32:22: error: duplicate case value
+ #define ERR_ENTRY(E) case CURLE_##E: return #E;
+ ^
+src/lcerr_easy.h:74:1: note: in expansion of macro 'ERR_ENTRY'
+ ERR_ENTRY ( SSL_CACERT )
+ ^~~~~~~~~
+src/lcerror.c:32:22: note: previously used here
+ #define ERR_ENTRY(E) case CURLE_##E: return #E;
+ ^
+src/lcerr_easy.h:65:1: note: in expansion of macro 'ERR_ENTRY'
+ ERR_ENTRY ( PEER_FAILED_VERIFICATION )
+ ^~~~~~~~~
+---
+ src/lcerr_easy.h | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/src/lcerr_easy.h b/src/lcerr_easy.h
+index 94ad143..895c6d8 100644
+--- a/src/lcerr_easy.h
++++ b/src/lcerr_easy.h
+@@ -62,7 +62,11 @@ ERR_ENTRY ( UNKNOWN_TELNET_OPTION ) /* User specified an unknown option */
+ #endif
+ ERR_ENTRY ( TELNET_OPTION_SYNTAX )
+ ERR_ENTRY ( OBSOLETE50 )
++#if LCURL_CURL_VER_GE(7,62,0)
++ERR_ENTRY ( OBSOLETE51 )
++#else
+ ERR_ENTRY ( PEER_FAILED_VERIFICATION )
++#endif
+ ERR_ENTRY ( GOT_NOTHING )
+ ERR_ENTRY ( SSL_ENGINE_NOTFOUND )
+ ERR_ENTRY ( SSL_ENGINE_SETFAILED )
+@@ -71,7 +75,11 @@ ERR_ENTRY ( RECV_ERROR )
+ ERR_ENTRY ( OBSOLETE57 )
+ ERR_ENTRY ( SSL_CERTPROBLEM )
+ ERR_ENTRY ( SSL_CIPHER )
++#if LCURL_CURL_VER_GE(7,62,0)
++ERR_ENTRY ( PEER_FAILED_VERIFICATION )
++#else
+ ERR_ENTRY ( SSL_CACERT )
++#endif
+ ERR_ENTRY ( BAD_CONTENT_ENCODING )
+ ERR_ENTRY ( LDAP_INVALID_URL )
+ ERR_ENTRY ( FILESIZE_EXCEEDED )
+--
+2.19.2
+