aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-11 01:49:54 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-23 08:46:47 -0300
commitc99134e4fce2ccf8044abb0a536b53593dab9df7 (patch)
treeeac43441368e83825402b70c6f6b1dcffe670fd8
parentda4171bbadc192ad7e1bba855b8e76a79d2b00dc (diff)
downloadaports-c99134e4fce2ccf8044abb0a536b53593dab9df7.tar.bz2
aports-c99134e4fce2ccf8044abb0a536b53593dab9df7.tar.xz
testing/xdg-desktop-portal-gtk: upgrade to 1.5.0
-rw-r--r--testing/xdg-desktop-portal-gtk/APKBUILD14
-rw-r--r--testing/xdg-desktop-portal-gtk/x11.patch32
2 files changed, 42 insertions, 4 deletions
diff --git a/testing/xdg-desktop-portal-gtk/APKBUILD b/testing/xdg-desktop-portal-gtk/APKBUILD
index c70266a30f..a9b6e8d2e9 100644
--- a/testing/xdg-desktop-portal-gtk/APKBUILD
+++ b/testing/xdg-desktop-portal-gtk/APKBUILD
@@ -1,16 +1,19 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=xdg-desktop-portal-gtk
-pkgver=1.4.0
+pkgver=1.5.0
pkgrel=0
pkgdesc="Gtk implementation of xdg-desktop-portal"
url="https://github.com/flatpak/xdg-desktop-portal-gtk"
arch="all"
license="LGPL-2.1-or-later"
depends="xdg-desktop-portal"
-makedepends="gtk+3.0-dev dbus-dev"
+makedepends="gtk+3.0-dev dbus-dev libx11
+ autoconf automake libtool"
subpackages="$pkgname-lang"
-source="https://github.com/flatpak/xdg-desktop-portal-gtk/releases/download/${pkgver}/xdg-desktop-portal-gtk-${pkgver}.tar.xz"
+source="https://github.com/flatpak/xdg-desktop-portal-gtk/releases/download/$pkgver/xdg-desktop-portal-gtk-$pkgver.tar.xz
+ x11.patch
+ "
prepare() {
default_prepare
@@ -22,6 +25,8 @@ prepare() {
-i depcomp \
-i config.sub \
-i config.guess
+
+ autoreconf -fi
}
build() {
@@ -43,4 +48,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="200fa490c486fbd61279cd6786b55b7ae85d88026d13b3d2d337d69d5d0c0f56babc9c0a8217b26e4771cd8d77c05871b9689e42b170a413083c4004d62db9ed xdg-desktop-portal-gtk-1.4.0.tar.xz"
+sha512sums="44e16161edac74a0a870a1dfa15eaad14eaa778abbaa48c11bb690b73fb250b3fd9326f7caf8cb797b4a7c3fa945adf3dee8c328631b1589e46773e3fd8f227b xdg-desktop-portal-gtk-1.5.0.tar.xz
+899867929a0ba9a28fb05db056514b6c97869c619c9919f85ecc831ceaf3568fa9aa35ad4409f2458dab9e262bb0eca791e92b990424d59fd4ca74f6498a3846 x11.patch"
diff --git a/testing/xdg-desktop-portal-gtk/x11.patch b/testing/xdg-desktop-portal-gtk/x11.patch
new file mode 100644
index 0000000000..85b5595992
--- /dev/null
+++ b/testing/xdg-desktop-portal-gtk/x11.patch
@@ -0,0 +1,32 @@
+From 92f478e907094004dbe367db3f6fb42f7fecf5af Mon Sep 17 00:00:00 2001
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
+Date: Fri, 4 Oct 2019 21:04:17 +0000
+Subject: [PATCH] configure: Add missing dep on libX11
+
+Fixes a link error:
+
+ CCLD xdg-desktop-portal-gtk
+/usr/bin/ld: src/xdg_desktop_portal_gtk-gsd-remote-display-manager.o: undefined reference to symbol 'XQueryExtension'
+/usr/bin/ld: /usr/lib/libX11.so.6: error adding symbols: DSO missing from command line
+collect2: error: ld returned 1 exit status
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 88a9cba..b532412 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -61,7 +61,7 @@ PKG_CHECK_MODULES(GTK, [xdg-desktop-portal >= 1.0 glib-2.0 >= 2.44 gio-unix-2.0
+ AC_SUBST(GTK_CFLAGS)
+ AC_SUBST(GTK_LIBS)
+
+-PKG_CHECK_MODULES(GTK_X11, gtk+-x11-3.0,
++PKG_CHECK_MODULES(GTK_X11, [gtk+-x11-3.0 x11],
+ have_gtk_x11=yes, have_gtk_x11=no)
+ if test "$have_gtk_x11" = "yes"; then
+ AC_DEFINE(HAVE_GTK_X11, 1, [define if we we have gtk+-x11])
+--
+2.23.0
+
+