aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-02-11 13:08:05 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2016-02-11 13:08:09 +0100
commitf7fd0ebc942d99a6deb46206866fb4989e2ea078 (patch)
treeedcca6648a50f0dcef4e3e7cf27c19c6be6e4fc2
parent8bc4a45054f8d5dfd981e2b0b4c77f0db547cc41 (diff)
downloadaports-f7fd0ebc942d99a6deb46206866fb4989e2ea078.tar.bz2
aports-f7fd0ebc942d99a6deb46206866fb4989e2ea078.tar.xz
testing/domoticz: move static www to usr/share
-rw-r--r--testing/domoticz/APKBUILD7
-rw-r--r--testing/domoticz/domoticz.confd2
-rw-r--r--testing/domoticz/domoticz.pre-install3
3 files changed, 7 insertions, 5 deletions
diff --git a/testing/domoticz/APKBUILD b/testing/domoticz/APKBUILD
index 39c097525c..ff49fa9183 100644
--- a/testing/domoticz/APKBUILD
+++ b/testing/domoticz/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=domoticz
pkgver=20160207
-pkgrel=2
+pkgrel=3
pkgdesc="Open source Home Automation System"
url="http://www.domoticz.com/"
arch="all"
@@ -53,9 +53,12 @@ build() {
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
- mkdir -p "$pkgdir"/usr/bin
+ mkdir -p "$pkgdir"/usr/bin \
+ "$pkgdir"/usr/share/$pkgname || return 1
mv "$pkgdir"/var/lib/domoticz/domoticz \
"$pkgdir"/usr/bin/ || return 1
+ mv "$pkgdir"/var/lib/domoticz/www \
+ "$pkgdir"/usr/share/$pkgname/ || return 1
rm -f "$pkgdir"/var/lib/domoticz/updatedomo
chown -R $pkgname "$pkgdir"/var/lib/domoticz || return 1
install -D -m755 "$srcdir"/$pkgname.initd \
diff --git a/testing/domoticz/domoticz.confd b/testing/domoticz/domoticz.confd
index ab3c49757a..31ee17f1ef 100644
--- a/testing/domoticz/domoticz.confd
+++ b/testing/domoticz/domoticz.confd
@@ -2,6 +2,6 @@
user="domoticz"
dbase="/var/lib/domoticz/domoticz.db"
userdata="/var/lib/domoticz/"
-wwwroot="/var/lib/domoticz/www/"
+wwwroot="/usr/share/domoticz/www/"
pidfile="/var/run/domoticz/domoticz.pid"
daemon_args=""
diff --git a/testing/domoticz/domoticz.pre-install b/testing/domoticz/domoticz.pre-install
index 78026bfedb..a94a5fb50b 100644
--- a/testing/domoticz/domoticz.pre-install
+++ b/testing/domoticz/domoticz.pre-install
@@ -1,4 +1,3 @@
#!/bin/sh
-adduser -H -D -s /sbin/nologin domoticz 2>/dev/null
-adduser domoticz usb 2>/dev/null
+adduser -h /var/lib/domoticz -D -s /sbin/nologin domoticz 2>/dev/null
exit 0