aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-12-04 14:24:45 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-12-04 15:06:48 +0100
commit2bbc4981c38a6a651251cd99af756c034d9f5de7 (patch)
treeed0e674f5d99af3c6f865590275a07f5958eb36d
parent2d4c75fe4f9782ba3d6904ca120fb9145ad2485c (diff)
downloadaports-2bbc4981c38a6a651251cd99af756c034d9f5de7.tar.bz2
aports-2bbc4981c38a6a651251cd99af756c034d9f5de7.tar.xz
main/backuppc: remove deprecated defined(@array)
Fixes http://bugs.alpinelinux.org/issues/6457
-rw-r--r--main/backuppc/APKBUILD6
-rw-r--r--main/backuppc/remove-deprecated-perl-defined-at.patch23
2 files changed, 28 insertions, 1 deletions
diff --git a/main/backuppc/APKBUILD b/main/backuppc/APKBUILD
index 006272c376..e2e5b69b07 100644
--- a/main/backuppc/APKBUILD
+++ b/main/backuppc/APKBUILD
@@ -3,7 +3,7 @@
pkgname="backuppc"
_realname="BackupPC"
pkgver=3.3.1
-pkgrel=4
+pkgrel=5
pkgdesc="High-performance, enterprise-grade backup system"
url="http://backuppc.sourceforge.net/"
arch="noarch"
@@ -15,6 +15,7 @@ pkggroups="backuppc"
install="$pkgname.pre-install"
source="http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$_realname-$pkgver.tar.gz
configure.pl.patch
+ remove-deprecated-perl-defined-at.patch
backuppc.initd"
builddir="$srcdir/$_realname-$pkgver"
@@ -71,10 +72,13 @@ package() {
md5sums="5efdcdd48e9e0d4ef7a706902d1f8b3d BackupPC-3.3.1.tar.gz
2a25b036d273ea67b69aa62e4cd7c28f configure.pl.patch
+eaff2abac13ea00427e9c895e0dc881c remove-deprecated-perl-defined-at.patch
d53014f185a18bd23bb52fe0fc622ca7 backuppc.initd"
sha256sums="c9cc4aec28a7474a68d40f4bc460ff15140e05c96900c7f98ff3ef06c4f6ae4c BackupPC-3.3.1.tar.gz
86988fbe8e8763abee8861f5bb03bf6bb7fd2430623f78fc921502b6759ad48d configure.pl.patch
+202cb3b03bccd3f2af97db737e67ed8daf2a015ca0bb86b8908d8b5cee9ae9db remove-deprecated-perl-defined-at.patch
54d26ee05424c6ad679f5307f9c687d48fe438cd89b789a8d0c16b2fa813cd39 backuppc.initd"
sha512sums="b6bb9de3103c5062098d80755055b7461ae9133a4a46a66b3d0af89d081086571694db1898e7d85880defa15b030bad522812116ae5361c0fbde90b877d139c6 BackupPC-3.3.1.tar.gz
a38361fd0e54a4c0100a7bf94b09483e5ba246dc45d6955d275542dd5662d8da11d9580685195b7d4dfa9a07c0487a52a14a95340737e70889ffe5c5e26d5ff8 configure.pl.patch
+f834c223fd14db6401d0eb162d7794dcc9d040d397f914386769bc3dd82209078c6d0dc331ee1d8943a8ea07ad8c2975929511617b2cd85e85db4f5bbd5fff09 remove-deprecated-perl-defined-at.patch
fb8558b0c9fb465084c848e32d072e6078a9ba3f1ccb2d602b8551ff51a2b88cd52177094519e741b3261e34eadbab50e6fb3be5ceed2fe476b8e6df0123d5b6 backuppc.initd"
diff --git a/main/backuppc/remove-deprecated-perl-defined-at.patch b/main/backuppc/remove-deprecated-perl-defined-at.patch
new file mode 100644
index 0000000000..471c767569
--- /dev/null
+++ b/main/backuppc/remove-deprecated-perl-defined-at.patch
@@ -0,0 +1,23 @@
+From 1261ba6d7a7ba0c973f25b8a63987360a639e16c Mon Sep 17 00:00:00 2001
+From: Alexander Moisseev <moiseev@mezonplus.ru>
+Date: Wed, 7 Jan 2015 15:11:49 +0300
+Subject: [PATCH] Browse.pm: - Remove deprecated defined(@array) perl5160delta:
+ http://perldoc.perl.org/perldiag.html#defined(@array)-is-deprecated
+
+---
+ lib/BackupPC/CGI/Browse.pm | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/BackupPC/CGI/Browse.pm b/lib/BackupPC/CGI/Browse.pm
+index 7309955..fea400f 100644
+--- a/lib/BackupPC/CGI/Browse.pm
++++ b/lib/BackupPC/CGI/Browse.pm
+@@ -65,7 +65,7 @@ sub action
+ #
+ # default to the newest backup
+ #
+- if ( !defined($In{num}) && defined(@Backups) && @Backups > 0 ) {
++ if ( !defined($In{num}) && @Backups > 0 ) {
+ $i = @Backups - 1;
+ $num = $Backups[$i]{num};
+ }