aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-07-18 19:54:18 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-07-18 19:54:18 +0000
commitbd52a4e50fa45b395acbb21874a9cbc7323210a4 (patch)
treec56cf6f05b87e2792c62626eb965860af7c92ce8
parent1ed50539aeb68ec66291654a911c085527a91954 (diff)
downloadaports-bd52a4e50fa45b395acbb21874a9cbc7323210a4.tar.bz2
aports-bd52a4e50fa45b395acbb21874a9cbc7323210a4.tar.xz
testing/py3-qt5: new aport
-rw-r--r--testing/py3-qt5/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/py3-qt5/APKBUILD b/testing/py3-qt5/APKBUILD
new file mode 100644
index 0000000000..5b6ad72ba6
--- /dev/null
+++ b/testing/py3-qt5/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-qt5
+_pkgname=PyQt
+pkgver=5.6
+pkgrel=0
+pkgdesc="A set of Python 3 bindings for the Qt toolkit"
+url="http://riverbankcomputing.co.uk/software/pyqt/intro"
+arch="all"
+license="GPL2+"
+depends="py3-sip"
+makedepends="python3-dev py-dbus-dev qt5-qtbase-dev py3-sip-dev libx11-dev"
+subpackages=""
+install=""
+source="http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.zip"
+
+builddir="${srcdir}/PyQt5_gpl-${pkgver}"
+build() {
+ cd "$builddir"
+ python3 configure.py \
+ --confirm-license \
+ --qmake /usr/lib/qt5/bin/qmake \
+ -v /usr/share/sip \
+ --qsci-api
+ # Thanks Gerardo for the rpath fix
+ find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
+ make || return 1
+}
+
+package(){
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install || return 1
+}
+
+md5sums="916e79bacda1799f8db7bc034043e450 PyQt5_gpl-5.6.zip"
+sha256sums="792125d162d5e9222df1adbbfbaee3a929204d5598e97690be8d8af9e88d9849 PyQt5_gpl-5.6.zip"
+sha512sums="86befc7505e12784a2b2fe3d48c98ef1a90c6ae8d0cb5d8f494dbc183b1e64d0e4acace2191d205408c070dc418a81a43e9666ffe9e734a822b205cdc883ee8c PyQt5_gpl-5.6.zip"