aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-12-15 11:06:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-12-15 11:06:45 +0000
commit49a4d9d83fca66b27bcdfacb1bfac43f9b8d3028 (patch)
treede510975fb7732e16eebb1477cbb08ca65c45a71
parent2da3ca85659652620b6914291326f18e4b0f8079 (diff)
downloadaports-49a4d9d83fca66b27bcdfacb1bfac43f9b8d3028.tar.bz2
aports-49a4d9d83fca66b27bcdfacb1bfac43f9b8d3028.tar.xz
main/qemu: fix build on aarch64
-rw-r--r--main/qemu/0001-linux-user-fix-build-with-musl-on-aarch64.patch34
-rw-r--r--main/qemu/APKBUILD4
2 files changed, 38 insertions, 0 deletions
diff --git a/main/qemu/0001-linux-user-fix-build-with-musl-on-aarch64.patch b/main/qemu/0001-linux-user-fix-build-with-musl-on-aarch64.patch
new file mode 100644
index 0000000000..9bb534cebe
--- /dev/null
+++ b/main/qemu/0001-linux-user-fix-build-with-musl-on-aarch64.patch
@@ -0,0 +1,34 @@
+From 806cb2ed28a16cf2894fabef034347f426f1d04e Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu, 15 Dec 2016 11:53:07 +0100
+Subject: [PATCH] linux-user: fix build with musl on aarch64
+
+Use the standard uint64_t instead of internal __u64.
+
+This fixes compiler error with musl libc on aarch64:
+.../qemu-2.7.0/linux-user/host/aarch64/hostdep.h:28:5:
+error: unknown type name '__u64'
+ __u64 *pcreg = &uc->uc_mcontext.pc;
+ ^~~~~
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ linux-user/host/aarch64/hostdep.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/linux-user/host/aarch64/hostdep.h b/linux-user/host/aarch64/hostdep.h
+index 64f75cef49..6fd6e36b2a 100644
+--- a/linux-user/host/aarch64/hostdep.h
++++ b/linux-user/host/aarch64/hostdep.h
+@@ -25,7 +25,7 @@ extern char safe_syscall_end[];
+ static inline void rewind_if_in_safe_syscall(void *puc)
+ {
+ struct ucontext *uc = puc;
+- __u64 *pcreg = &uc->uc_mcontext.pc;
++ uint64_t *pcreg = &uc->uc_mcontext.pc;
+
+ if (*pcreg > (uintptr_t)safe_syscall_start
+ && *pcreg < (uintptr_t)safe_syscall_end) {
+--
+2.11.0
+
diff --git a/main/qemu/APKBUILD b/main/qemu/APKBUILD
index 85d37f7261..892991cc85 100644
--- a/main/qemu/APKBUILD
+++ b/main/qemu/APKBUILD
@@ -120,6 +120,7 @@ subpackages="$subpackages $pkgname-img" # -img must be declared the last
source="http://wiki.qemu-project.org/download/$pkgname-$pkgver.tar.bz2
0001-elfload-load-PIE-executables-to-right-address.patch
0006-linux-user-signal.c-define-__SIGRTMIN-MAX-for-non-GN.patch
+ 0001-linux-user-fix-build-with-musl-on-aarch64.patch
musl-F_SHLCK-and-F_EXLCK.patch
fix-sigevent-and-sigval_t.patch
configure-ifunc.patch
@@ -283,6 +284,7 @@ guest() {
md5sums="08d4d06d1cb598efecd796137f4844ab qemu-2.7.0.tar.bz2
672727bb1d8c8ab7b5def65dd1793c33 0001-elfload-load-PIE-executables-to-right-address.patch
d364208c4847ad2baeb237900befecd1 0006-linux-user-signal.c-define-__SIGRTMIN-MAX-for-non-GN.patch
+38fbaee6f2913993169e5b39d96927a1 0001-linux-user-fix-build-with-musl-on-aarch64.patch
bc5f2e41ed3b6d6d30b672adab82e3e1 musl-F_SHLCK-and-F_EXLCK.patch
9afbd6c9586229ce64275f012d665e2a fix-sigevent-and-sigval_t.patch
a3ec1de5e0513c97a83d211f182a634c configure-ifunc.patch
@@ -293,6 +295,7 @@ a2f5570453f2489b6e4023e96f70cb7e bridge.conf"
sha256sums="326e739506ba690daf69fc17bd3913a6c313d9928d743bd8eddb82f403f81e53 qemu-2.7.0.tar.bz2
af35304b165622a53f7557b59ffd8da5030f5fd444e669c862f9410131f3b987 0001-elfload-load-PIE-executables-to-right-address.patch
6af6cf9044997710a6d0fbdba30a35c8d775e30d30c032ec97db672f75ec88ac 0006-linux-user-signal.c-define-__SIGRTMIN-MAX-for-non-GN.patch
+1086ee9ea9411b3bacaf58bc72630a159260ef873a66710b7edb7223be1ea2c0 0001-linux-user-fix-build-with-musl-on-aarch64.patch
eefd597197223899d3b12d8274af493153e270fd06ea8622e33d6eaeae063d40 musl-F_SHLCK-and-F_EXLCK.patch
9abdf3410dea742cac3552363950c8a7fbcec8dd2bfd68e3c417a284f4e702f5 fix-sigevent-and-sigval_t.patch
73a87efa545ee16b8bef9ddea870da29f0eed71a8a6934d2888577b03088286b configure-ifunc.patch
@@ -303,6 +306,7 @@ d84e53a94584f37f3bd1b21f44077b5de0d07094c6729f26ae20ab1f7b9cc298 qemu-guest-age
sha512sums="654acaa7b3724a288e5d7e2a26ab780d9c9ed9f647fba00a906cbaffbe9d58fd666f2d962514aa2c5b391b4c53811ac3170d2eb51727f090bd19dfe45ca9a9db qemu-2.7.0.tar.bz2
405008589cad1c8b609eca004d520bf944366e8525f85a19fc6e283c95b84b6c2429822ba064675823ab69f1406a57377266a65021623d1cd581e7db000134fd 0001-elfload-load-PIE-executables-to-right-address.patch
ec84b27648c01c6e58781295dcd0c2ff8e5a635f9836ef50c1da5d0ed125db1afc4cb5b01cb97606d6dd8f417acba93e1560d9a32ca29161a4bb730b302440ea 0006-linux-user-signal.c-define-__SIGRTMIN-MAX-for-non-GN.patch
+4431dad803156d424a6c9fc74783762590b27fcb3bfadb6b23b149bc9e71c31f139991541aa4e0583c17ac531242dff02ebf4d5a8f9a9a77be757fb30cb65565 0001-linux-user-fix-build-with-musl-on-aarch64.patch
5de10f7e8abae16d1d7521e5ca1bfb62a8f295b324bea84f122f882b7b9354c21e5a00b20a1c5484c1b737b937e53c4ca6979e55705522f0779a5669725369f5 musl-F_SHLCK-and-F_EXLCK.patch
e3f006c28318669356cd5b778f26774f06b0a40a4ac852573379df63efcc8276869958faec16797a38bf96c6061dfc040309e462d8559984f67eaf4af701ca1a fix-sigevent-and-sigval_t.patch
f51a2906b8685c007c6dbba9ecfe1cc3a34cad4fe1264a2d02e1add05a391d95bfe05524adf58d1a880d39a2b23bcce6a850265b82c49f64171019bdf38978de configure-ifunc.patch