aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-12-15 07:54:33 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-12-15 07:54:33 +0000
commit3f0dbb30cd71facbc26835998bd082e970c0a461 (patch)
treefa8c21340aa2f7614f1eba7a8fe7b9526a722e2d
parent072234a32659cc78375e5e10d7c884a541282e13 (diff)
downloadaports-3f0dbb30cd71facbc26835998bd082e970c0a461.tar.bz2
aports-3f0dbb30cd71facbc26835998bd082e970c0a461.tar.xz
testing/ttf-opensans: new aport
-rw-r--r--testing/ttf-opensans/APKBUILD28
-rw-r--r--testing/ttf-opensans/ttf-opensans.post-install4
2 files changed, 32 insertions, 0 deletions
diff --git a/testing/ttf-opensans/APKBUILD b/testing/ttf-opensans/APKBUILD
new file mode 100644
index 0000000000..d2adf0781d
--- /dev/null
+++ b/testing/ttf-opensans/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ttf-opensans
+pkgver=1.10
+pkgrel=0
+pkgdesc="Open Sans is a humanist sans serif typeface designed by Steve Matteson"
+url="http://opensans.com/"
+arch="noarch"
+license="Apache"
+depends="fontconfig mkfontdir mkfontscale"
+makedepends="font-util-dev"
+install="$pkgname.post-install"
+source="http://ie.archive.ubuntu.com/ftp.frugalware.org/pub/frugalware/frugalware-current/source/xlib-extra/open-sans/$pkgname-$pkgver.zip"
+builddir="$srcdir"
+
+build() {
+ cd "$builddir"
+ return 0
+}
+
+package() {
+ cd "$builddir"
+ install -d "$pkgdir/usr/share/fonts/TTF"
+ install -m644 *.ttf "$pkgdir/usr/share/fonts/TTF/"
+}
+md5sums="bfe34b6473988efb5de7cf226975249f ttf-opensans-1.10.zip"
+sha256sums="f14979b4a358311e51da601a2debb7f21a639912fa06d88825056c41d792871e ttf-opensans-1.10.zip"
+sha512sums="6e14d6bc8ed225d04016c237a43909032aae434111bd21b9e4a0889fa84b1dc6d4487d8c465f53308523ee93e7f45cf1f2e78a0db6c64b9a5d7f13a6b2579688 ttf-opensans-1.10.zip"
diff --git a/testing/ttf-opensans/ttf-opensans.post-install b/testing/ttf-opensans/ttf-opensans.post-install
new file mode 100644
index 0000000000..984457d3e1
--- /dev/null
+++ b/testing/ttf-opensans/ttf-opensans.post-install
@@ -0,0 +1,4 @@
+#!/bin/sh
+fc-cache -f > /dev/null
+mkfontscale /usr/share/fonts/TTF
+mkfontdir /usr/share/fonts/TTF