aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2016-09-22 22:16:21 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-09-23 02:12:01 +0200
commit249001e1f16cef7e910455cb67c5d4773e5caad9 (patch)
tree846967de3428cfcf34cc028f8a8a1dd77ceaa757
parenta440dec1fa122bec99c6d624163f749edf6ed1a0 (diff)
downloadaports-249001e1f16cef7e910455cb67c5d4773e5caad9.tar.bz2
aports-249001e1f16cef7e910455cb67c5d4773e5caad9.tar.xz
community/perl-io-socket-inet6: move from testing
-rw-r--r--community/perl-io-socket-inet6/APKBUILD (renamed from testing/perl-io-socket-inet6/APKBUILD)16
1 files changed, 7 insertions, 9 deletions
diff --git a/testing/perl-io-socket-inet6/APKBUILD b/community/perl-io-socket-inet6/APKBUILD
index 9577993b42..b99aa4ad13 100644
--- a/testing/perl-io-socket-inet6/APKBUILD
+++ b/community/perl-io-socket-inet6/APKBUILD
@@ -9,29 +9,27 @@ pkgdesc="Object interface for AF_INET|AF_INET6 domain sockets"
url="http://search.cpan.org/dist/IO-Socket-INET6/"
arch="noarch"
license="GPL PerlArtistic"
-cpandepends="perl-socket6"
-cpanmakedepends=" "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends perl-module-build"
+depends="perl-socket6"
+makedepends="perl-dev perl-module-build"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/$_pkgreal-$pkgver.tar.gz"
-
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ default_prepare || return 1
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
perl Build.PL installdirs=vendor || return 1
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
./Build ### && ./Build test #no ipv6 in buildozer
}
package() {
- cd "$_builddir"
+ cd "$builddir"
./Build install destdir="$pkgdir" || return 1
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}