aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-10-09 22:15:44 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-10-09 22:16:45 +0200
commitc5f742df3da1536cf6154e30f5b50da7582df988 (patch)
treea79408f0e728793483cbc02cb94162576388b0be
parent0c002197efbb534647033ee48e8760039a49d685 (diff)
downloadaports-c5f742df3da1536cf6154e30f5b50da7582df988.tar.bz2
aports-c5f742df3da1536cf6154e30f5b50da7582df988.tar.xz
testing/gwsocket: new aport
http://gwsocket.io/ A simple, standalone, language-agnostic, RFC6455 compliant WebSocket Server
-rw-r--r--testing/gwsocket/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/gwsocket/APKBUILD b/testing/gwsocket/APKBUILD
new file mode 100644
index 0000000000..3c479e4758
--- /dev/null
+++ b/testing/gwsocket/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=gwsocket
+pkgver=0.1
+pkgrel=0
+pkgdesc="A simple, standalone, language-agnostic, RFC6455 compliant WebSocket Server"
+url="http://gwsocket.io"
+arch="all"
+license="MIT"
+depends=""
+makedepends="autoconf automake"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/allinurl/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ autoreconf -fiv
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="0a542e2f6dff97dc8384586bd6e5ed3e gwsocket-0.1.tar.gz"
+sha256sums="26894e568898d416c41440b14fd1482d2a0774471ebf9677a2a429a0da0f5961 gwsocket-0.1.tar.gz"
+sha512sums="d51b47b338df4b83900311cb9fdd9a0dbd21b41ed3c345c5d08b8da332d6ff82d060818cae03de1d404d0787683d6ffc301ebf762dae631df4891ae74923166a gwsocket-0.1.tar.gz"