aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Riedesel <mark@klowner.com>2016-08-10 16:57:08 -0500
committerJakub Jirutka <jakub@jirutka.cz>2016-08-14 20:03:02 +0200
commit47c4c32a7954941a3250746a1e4910ce55875910 (patch)
tree3a680de8bc3bb5e106f83b51ec2a0e74c03bf9d5
parentb64569ea04735b7cb38a615ba67f61b1f0cb8927 (diff)
downloadaports-47c4c32a7954941a3250746a1e4910ce55875910.tar.bz2
aports-47c4c32a7954941a3250746a1e4910ce55875910.tar.xz
testing/yaml-cpp: new aport
https://github.com/jbeder/yaml-cpp YAML parser and emitter in C++ matching YAML 1.2 spec
-rw-r--r--testing/yaml-cpp/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/yaml-cpp/APKBUILD b/testing/yaml-cpp/APKBUILD
new file mode 100644
index 0000000000..507454d944
--- /dev/null
+++ b/testing/yaml-cpp/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Mark Riedesel <mark@klowner.com>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=yaml-cpp
+pkgver=0.5.3
+pkgrel=0
+pkgdesc="YAML parser and emitter in C++ matching YAML 1.2 spec"
+url="https://github.com/jbeder/yaml-cpp"
+arch="all"
+license="MIT"
+depends=""
+# Note: dependency on boost-dev is planned to be removed in next release (0.6).
+depends_dev="boost-dev"
+makedepends="$depends_dev cmake"
+subpackages="$pkgname-dev"
+source="https://github.com/jbeder/yaml-cpp/archive/yaml-cpp-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ mkdir -p build && cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=ON
+}
+
+package() {
+ cd "$builddir"/build
+
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="4e47733d98266e46a1a73ae0a72954eb yaml-cpp-0.5.3.tar.gz"
+sha256sums="668d7df0a43daba06e5b36aaa460ac902713ca4feb6b2d2697661607a0bc66ee yaml-cpp-0.5.3.tar.gz"
+sha512sums="cb11acccc5261e4513b597becf6be5d7fef05ef89a11eda3fc7db9e513adf953a2ec9c1bf70b91277076d793f0c65a496c7243d9b4a4240623e5f7034f8d4ad3 yaml-cpp-0.5.3.tar.gz"