aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-12-16 13:03:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-12-16 13:03:59 +0000
commit0c70871294198eb9a0e2b6fb63b5a7f4a49225f0 (patch)
tree3ed20b49a6506a5f306d39c2942df1d406c70935
parent0c762268fc526343e34d47c98f15b59773df1301 (diff)
parentb5a2c23228630d74a56958aa15d76780e393e27b (diff)
downloadaports-0c70871294198eb9a0e2b6fb63b5a7f4a49225f0.tar.bz2
aports-0c70871294198eb9a0e2b6fb63b5a7f4a49225f0.tar.xz
Merge git://github.com/Barthalion/aports
upgraded monkey, luajit, calcurse, dnsmasq, postfix, haveged and nginx
-rw-r--r--main/bison/APKBUILD4
-rw-r--r--main/dnsmasq/APKBUILD5
-rw-r--r--main/nginx/APKBUILD4
-rw-r--r--main/postfix/APKBUILD4
-rw-r--r--testing/calcurse/APKBUILD4
-rw-r--r--testing/haveged/APKBUILD48
-rw-r--r--testing/luajit/APKBUILD24
-rw-r--r--testing/monkey/APKBUILD8
8 files changed, 42 insertions, 59 deletions
diff --git a/main/bison/APKBUILD b/main/bison/APKBUILD
index fbc5dbe5af..1c0d327934 100644
--- a/main/bison/APKBUILD
+++ b/main/bison/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bison
-pkgver=2.6.5
+pkgver=2.7
pkgrel=0
pkgdesc="The GNU general-purpose parser generator"
arch="all"
@@ -30,4 +30,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="75c8508e0a9e5c68f608658672d6bda4 bison-2.6.5.tar.xz"
+md5sums="234cdfac99257cf99ac4a03c898f37b9 bison-2.7.tar.xz"
diff --git a/main/dnsmasq/APKBUILD b/main/dnsmasq/APKBUILD
index 75b5426ee3..82cdbdb2a3 100644
--- a/main/dnsmasq/APKBUILD
+++ b/main/dnsmasq/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dnsmasq
-pkgver=2.64
+pkgver=2.65
pkgrel=0
pkgdesc="Small forwarding DNS server"
url="http://www.thekelleys.org.uk/dnsmasq/"
@@ -37,6 +37,7 @@ package() {
install -D -m644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
install dnsmasq.conf.example "$pkgdir"/etc/dnsmasq.conf
}
-md5sums="60adb8e01960a41ce67e0422c4cf9ab3 dnsmasq-2.64.tar.gz
+
+md5sums="a91534a5d6f053d5c80f67ef502afa34 dnsmasq-2.65.tar.gz
006fed857314053b870ff1927c12ae78 dnsmasq.initd
16985abb08c8e11f85e38b37ea3863a4 dnsmasq.confd"
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index 0bf2878d41..47ef94c9a2 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
pkgname=nginx
-pkgver=1.2.5
+pkgver=1.2.6
pkgrel=0
pkgdesc="lightweight HTTP and reverse proxy server"
url="http://www.nginx.org"
@@ -54,7 +54,7 @@ package() {
install -m644 -D LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-md5sums="4f5a55187a3d45fa37d99d07ddd90800 nginx-1.2.5.tar.gz
+md5sums="1350d26eb9b66364d9143fb3c4366ab6 nginx-1.2.6.tar.gz
4faf8dff6ff1490edae1688baf1b2abb nginx.initd
8823274a834332d3db4f62bf7dd1fb7d nginx.logrotate
801a87f7f9d27f8ad85b41a78b4c4461 ipv6.patch"
diff --git a/main/postfix/APKBUILD b/main/postfix/APKBUILD
index 38ea25e7be..c69b0dc8f9 100644
--- a/main/postfix/APKBUILD
+++ b/main/postfix/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=postfix
-pkgver=2.9.4
+pkgver=2.9.5
pkgrel=1
pkgdesc="Secure and fast drop-in replacement for Sendmail (MTA)"
url="http://www.postfix.org/"
@@ -160,7 +160,7 @@ pcre() { _mv_dict pcre ; }
pgsql() { _mv_dict pgsql ; }
sqlite() { _mv_dict sqlite ; }
-md5sums="230bc3c00c051946eccd850058d75f6c postfix-2.9.4.tar.gz
+md5sums="588e1c54588e6da0c4b3436f1c2c2fb3 postfix-2.9.5.tar.gz
d773f01dcc965d219a8a37b88f89c5bf postfix.initd
8de3f108639eda995162c590053a1278 dynamic-maps3.patch
442efd1a95b0c061dfb8ab75456e0f24 dynamicmaps.cf
diff --git a/testing/calcurse/APKBUILD b/testing/calcurse/APKBUILD
index 064db112cf..f59a50daf9 100644
--- a/testing/calcurse/APKBUILD
+++ b/testing/calcurse/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
pkgname=calcurse
-pkgver=3.0.0
+pkgver=3.1.2
pkgrel=1
pkgdesc='A text-based personal organizer.'
url='http://calcurse.org/'
@@ -26,4 +26,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="3e25d04afeecd8f21e064e8b1db8f02b calcurse-3.0.0.tar.gz"
+md5sums="9ad32bd0efa9c8ed1e1d7df49aef5663 calcurse-3.1.2.tar.gz"
diff --git a/testing/haveged/APKBUILD b/testing/haveged/APKBUILD
index e3548c7a04..135dc37faa 100644
--- a/testing/haveged/APKBUILD
+++ b/testing/haveged/APKBUILD
@@ -1,51 +1,35 @@
+# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
# Contributor: Danilo Godec <danilo.godec@agenda.si>
-# Maintainer:
+
pkgname=haveged
-pkgver=1.2
+pkgver=1.6
pkgrel=1
-pkgdesc="haveged is a daemon that feeds the /dev/random pool on Linux"
+pkgdesc='Entropy harvesting daemon using CPU timings'
url="http://www.issihosts.com/haveged/"
arch="all"
license="GPL"
-depends=""
-depends_dev=""
-makedepends="$depends_dev"
-install=""
subpackages="$pkgname-doc"
source="http://www.issihosts.com/haveged/haveged-$pkgver.tar.gz
- haveged.initd haveged.confd"
+ haveged.initd haveged.confd"
_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
build() {
- cd "$_builddir"
- ./configure --prefix /usr --sysconfdir /etc
- make || return 1
- make check || return 1
+ cd "$_builddir"
+ ./configure --prefix /usr --sysconfdir /etc || return 1
+ make || return 1
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
- install -Dm644 AUTHORS "$pkgdir"/usr/share/doc/$pkgname/AUTHORS
- install -Dm644 ChangeLog "$pkgdir"/usr/share/doc/$pkgname/ChangeLog
- install -Dm644 INSTALL "$pkgdir"/usr/share/doc/$pkgname/INSTALL
- install -Dm644 NEWS "$pkgdir"/usr/share/doc/$pkgname/NEWS
- install -Dm644 README "$pkgdir"/usr/share/doc/$pkgname/README
- install -Dm755 "$srcdir"/haveged.initd "$pkgdir"/etc/init.d/haveged
- install -Dm644 "$srcdir"/haveged.confd "$pkgdir"/etc/conf.d/haveged
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+
+ install -Dm755 "$srcdir"/haveged.initd \
+ "$pkgdir"/etc/init.d/haveged || return 1
+ install -Dm644 "$srcdir"/haveged.confd \
+ "$pkgdir"/etc/conf.d/haveged || return 1
}
-md5sums="dc961f36c065239f2ddeeb840ddf9ec0 haveged-1.2.tar.gz
+md5sums="5a386a530e89bfbc6c8d22717b16e2a8 haveged-1.6.tar.gz
0718d29f820b878a311e939b3682935c haveged.initd
242300ea7948a16018d1b0f77fb5ec96 haveged.confd"
diff --git a/testing/luajit/APKBUILD b/testing/luajit/APKBUILD
index 7646ed1ba3..b01f66bb28 100644
--- a/testing/luajit/APKBUILD
+++ b/testing/luajit/APKBUILD
@@ -1,22 +1,18 @@
-# Contributor: Cameron Banta <cbanta@gmail.com>
# Maintainer: Cameron Banta <cbanta@gmail.com>
+# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+
pkgname=luajit
-_pkgname=LuaJIT
-pkgver=2.0.0_beta8
-_pkgver=${pkgver//_/-}
+pkgver=2.0.0
pkgrel=0
-pkgdesc="Just-In-Time Compiler for the Lua programming language"
-url="http://luajit.org"
+pkgdesc='Just-in-time compiler and replacement for Lua 5.1 '
+url='http://luajit.org'
arch="all"
license="MIT"
-depends=""
-depends_dev=""
makedepends="$depends_dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://luajit.org/download/$_pkgname-$_pkgver.tar.gz"
+source="http://luajit.org/download/LuaJIT-$pkgver.tar.gz"
-_builddir=$srcdir/$_pkgname-$_pkgver
+_builddir=$srcdir/LuaJIT-$pkgver
build() {
cd "$_builddir"
@@ -26,7 +22,9 @@ build() {
package() {
cd "$_builddir"
make install DESTDIR="$pkgdir" PREFIX=/usr || return 1
- ln -sf /usr/bin/luajit-${_pkgver} $pkgdir/usr/bin/luajit
+
+ install -Dm644 "$_builddir"/COPYRIGHT \
+ $pkgdir/usr/share/licenses/$pkgname/COPYRIGHT
}
-md5sums="f0748a73ae268d49b1d01f56c4fe3e61 LuaJIT-2.0.0-beta8.tar.gz"
+md5sums="97a2b87cc0490784f54b64cfb3b8f5ad LuaJIT-2.0.0.tar.gz"
diff --git a/testing/monkey/APKBUILD b/testing/monkey/APKBUILD
index 32082b7ccf..e4d91e2828 100644
--- a/testing/monkey/APKBUILD
+++ b/testing/monkey/APKBUILD
@@ -1,15 +1,15 @@
# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
pkgname=monkey
-pkgver=1.0.1
+pkgver=1.1.1
pkgrel=0
pkgdesc='A fast and lightweight HTTP server designed for embedded devices.'
url='http://monkey-project.com/'
license='GPL2'
arch='all'
-makedepends='bash'
+makedepends='bash findutils'
subpackages="$pkgname-doc"
-source="http://monkey-project.com/releases/1.0/$pkgname-$pkgver.tar.gz
+source="http://monkey-project.com/releases/1.1/$pkgname-$pkgver.tar.gz
strsignal.patch
monkey.initd
monkey.confd"
@@ -55,7 +55,7 @@ package() {
"$pkgdir"/etc/conf.d/monkey || return 1
}
-md5sums="5e08e4089e8b41ea90b0c98d6ca6433e monkey-1.0.1.tar.gz
+md5sums="958d74ddcc595ae01b1d3916e9e7753c monkey-1.1.1.tar.gz
4e99ccbfbd00b17023c7b82e466c7aee strsignal.patch
6630131d3ea75dbbf1033a4acc8cf983 monkey.initd
71805f446a12d747c52e18b8ac4b4704 monkey.confd"