aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-05-23 02:21:43 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2015-05-23 02:21:43 +0200
commit90a47e4188342ab7e6af98b037d310de91e5d718 (patch)
treef545d8eba48e21c4aa1f4ae5b935414ff9c945a2
parent47c92a0a7cf8c596a31f203c7a2423e418a3ae17 (diff)
downloadaports-90a47e4188342ab7e6af98b037d310de91e5d718.tar.bz2
aports-90a47e4188342ab7e6af98b037d310de91e5d718.tar.xz
testing/lucene++: enable again
-rw-r--r--testing/lucene++/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/testing/lucene++/APKBUILD b/testing/lucene++/APKBUILD
index c3d0c4e01e..f5fc33e7fa 100644
--- a/testing/lucene++/APKBUILD
+++ b/testing/lucene++/APKBUILD
@@ -5,11 +5,11 @@ pkgver=3.0.7
pkgrel=0
pkgdesc="C++ port of the popular Java Lucene library"
url="https://github.com/luceneplusplus/LucenePlusPlus'"
-arch=""
+arch="all"
license="GPL Apache"
depends=""
depends_dev="boost-dev"
-makedepends="$depends_dev cmake linux-headers"
+makedepends="$depends_dev cmake linux-headers ccache"
install=""
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_3.0.7.tar.gz"
@@ -29,6 +29,9 @@ prepare() {
build() {
mkdir "$_builddir"/build
cd "$_builddir"/build
+ # stupid (but functional) hack to prevent fority header to break
+ # the build. Remeber to remove ccache from deps when fixed.
+ export PATH="/usr/lib/ccache/bin/:$PATH"
cmake "$_builddir" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_DESTINATION=/usr/lib \