aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-08-15 20:08:39 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-08-15 20:12:16 +0200
commit226d26e1e95960faf263f2b356f0d8b3555422f3 (patch)
tree89b8718d2757baa66ff93a27e79d20bbece41b09
parenta908fc50717f46cb66245e6dc4c9489e1368f1bb (diff)
downloadaports-226d26e1e95960faf263f2b356f0d8b3555422f3.tar.bz2
aports-226d26e1e95960faf263f2b356f0d8b3555422f3.tar.xz
testing/pcre2: simplify abuild
-rw-r--r--testing/pcre2/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/testing/pcre2/APKBUILD b/testing/pcre2/APKBUILD
index 37ed2f277f..3eb6a4489e 100644
--- a/testing/pcre2/APKBUILD
+++ b/testing/pcre2/APKBUILD
@@ -11,7 +11,7 @@ depends=""
depends_dev="libedit-dev zlib-dev"
makedepends="$depends_dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools
- libpcre2-16:libpcre16 libpcre2-32:libpcre32"
+ libpcre2-16:_libpcre libpcre2-32:_libpcre"
source="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
@@ -43,14 +43,12 @@ package() {
}
_libpcre() {
- local bits="$1"
+ local bits="${subpkgname##*-}"
pkgdesc="PCRE2 with $bits bit character support"
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/libpcre2-$bits.so* "$subpkgdir"/usr/lib/
}
-libpcre16() { _libpcre 16; }
-libpcre32() { _libpcre 32; }
tools() {
pkgdesc="Auxiliary utilities for PCRE2"