aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2018-06-25 15:13:41 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2018-06-25 15:14:34 +0000
commitdce52d389f9ef1dde80d38f6e8bf4600c40e065f (patch)
treee8be298341d7611bafc4eb6a1ba085fe52f4517c
parentbd4bb5a3475e16f68333a118c10a23fc0bd98a12 (diff)
downloadaports-dce52d389f9ef1dde80d38f6e8bf4600c40e065f.tar.bz2
aports-dce52d389f9ef1dde80d38f6e8bf4600c40e065f.tar.xz
main/raspberrypi: upgrade to 0.20171114 and add aarch64
-rw-r--r--main/raspberrypi/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/main/raspberrypi/APKBUILD b/main/raspberrypi/APKBUILD
index 5394449818..b60eea745f 100644
--- a/main/raspberrypi/APKBUILD
+++ b/main/raspberrypi/APKBUILD
@@ -1,31 +1,34 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=raspberrypi
-pkgver=0.20171114
-_commitid=bc3c52a51315399a9f31ed24049eb4bc81fd1c60
+pkgver=0.20180511
+_commitid=2448644657e5fbfd82299416d218396ee1115ece
pkgrel=0
pkgdesc="Raspberry Pi support tools"
url="https://github.com/raspberrypi/userland"
-arch="armhf"
+arch="armhf aarch64"
license="BSD"
depends=""
depends_dev="linux-headers raspberrypi-libs"
makedepends="cmake $depends_dev"
install=""
-options="!fhs"
-subpackages="$pkgname-dev $pkgname-libs"
+options="!fhs !check"
+subpackages="$pkgname-dev $pkgname-libs $pkgname-openrc"
source="raspberrypi-$pkgver.tar.gz::https://github.com/raspberrypi/userland/archive/$_commitid.tar.gz
"
builddir="$srcdir"/userland-$_commitid
build() {
- mkdir -p "$builddir"
cd "$builddir"
- # -Wno-error=array-bounds is workaround for gcc bug 59124
- cmake -DCMAKE_C_FLAGS="$CFLAGS -D_GNU_SOURCE -Wno-error=array-bounds" \
- -DCMAKE_BUILD_TYPE=Release \
+ case "$CARCH" in
+ arm*) local ARM64=off;;
+ aarch64) local ARM64=on;;
+ esac
+ cmake -DCMAKE_C_FLAGS="$CFLAGS -D_GNU_SOURCE" \
+ -DARM64=$ARM64 \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_RPATH=/opt/vc/lib \
- $_sourcedir || return 1
+ $_sourcedir
make
}
@@ -45,4 +48,4 @@ libs() {
mv "$pkgdir"/opt/vc/lib/* "$subpkgdir"/opt/vc/lib
}
-sha512sums="d8295474e6bab7ad8f34b1ee5cf8e883b4c0a75bf6083012e2422707bdf36ee1ad11e9e61b2edaa77b40a80d1f529ac43d07e05d0cf87443bb5abf397430c19b raspberrypi-0.20171114.tar.gz"
+sha512sums="af764dc9490d94d4877833aa2816c8ceef2e12aca6ad95c9f4472dee4b06eb31d9f6707c0ce664e0d25ab7f5c296c48e827b1100c850946595e931e03c177ec6 raspberrypi-0.20180511.tar.gz"