aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-12-22 20:07:48 +0200
committerTimo Teräs <timo.teras@iki.fi>2014-12-22 20:07:48 +0200
commit36534066e67fbaeb7ffc3976e15a49fa23b4fe98 (patch)
treee2e6720da13c176fa40d41e6bbbe7ded8705a268
parent13ad215e465b5404a11fea1dda320daccf0bddc3 (diff)
downloadaports-36534066e67fbaeb7ffc3976e15a49fa23b4fe98.tar.bz2
aports-36534066e67fbaeb7ffc3976e15a49fa23b4fe98.tar.xz
main/lua5.2-xml: new aport
same as lua-xml but newer version with lua5.2 support
-rw-r--r--main/lua5.2-xml/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/main/lua5.2-xml/APKBUILD b/main/lua5.2-xml/APKBUILD
new file mode 100644
index 0000000000..d5134f341d
--- /dev/null
+++ b/main/lua5.2-xml/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua5.2-xml
+_name=LuaXML
+pkgver=130610
+pkgrel=0
+pkgdesc="a minimal set of functions for the processing of XML data in Lua"
+url="http://viremo.eludi.net/LuaXML/index.html"
+arch="all"
+license="MIT"
+depends=
+makedepends="lua5.2-dev"
+install=
+subpackages=
+source="http://viremo.eludi.net/LuaXML/LuaXML_$pkgver.zip"
+
+_builddir="$srcdir"
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ make \
+ INCDIR="$(pkg-config --cflags lua5.2)" \
+ LIBDIR="$(pkg-config --libs lua5.2)" \
+ || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -m755 -D LuaXML_lib.so "$pkgdir"/usr/lib/lua/5.2/LuaXML_lib.so\
+ || return 1
+ install -m755 -D LuaXml.lua "$pkgdir"/usr/share/lua/5.2/LuaXml.lua \
+ || return 1
+}
+
+md5sums="25e4c276c5d8716af1de0c7853aec2b4 LuaXML_130610.zip"
+sha256sums="f2c7475c9ff842d110cfcbc0d0859856b4df18baea3edb5b9379c41a92415e6e LuaXML_130610.zip"
+sha512sums="8f4ab1ba0b186ae8778ec7e2cdf5ebb403233ac9a551c6e476d0554bc27b0eb16a69a070c56747d59d6ee7aa53be70245d9be302ca69ea02226c3543b0ca654f LuaXML_130610.zip"