aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-01-01 11:10:02 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-01-01 11:10:02 +0000
commit646a884ce6ea7b83f3b5a03ad3e8b2e335fed5fb (patch)
treea790e5da74a8290556a1dc3bb073e478197e1b29
parent4866d515a5d72880e30d8d0aa93def05dd5a1f64 (diff)
downloadaports-646a884ce6ea7b83f3b5a03ad3e8b2e335fed5fb.tar.bz2
aports-646a884ce6ea7b83f3b5a03ad3e8b2e335fed5fb.tar.xz
testing/jbigkit: fix build for x86
-rw-r--r--testing/jbigkit/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/testing/jbigkit/APKBUILD b/testing/jbigkit/APKBUILD
index a969165c9e..07f28aa836 100644
--- a/testing/jbigkit/APKBUILD
+++ b/testing/jbigkit/APKBUILD
@@ -9,6 +9,7 @@ arch="all"
license="GPL"
# test fails
options="!check"
+makedepends="imagemagick-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="https://www.cl.cam.ac.uk/~mgk25/download/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
@@ -17,7 +18,11 @@ prepare() {
default_prepare
cd "$builddir"
unset CFLAGS CPPFLAGS LDFLAGS
- [ "$CARCH" == "x86_64" ] && export CFLAGS="$CFLAGS -fPIC"
+ if [ "$CARCH" == "x86_64" ]; then
+ export CFLAGS="$CFLAGS -fPIC"
+ else
+ export CFLAGS="$CFLAGS"
+ fi
}
build() {