aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Wagner <stw@bit-strickerei.de>2016-10-20 17:15:42 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-10-20 23:07:05 +0200
commita7224fc905a9ef3cf4a94a9581256c64c9ac9d1f (patch)
tree1cc4b50a470e9ba362604115eb0d70c72ade896d
parentff0f6608c0dcd819c1abeea2ef771d46196909c2 (diff)
downloadaports-a7224fc905a9ef3cf4a94a9581256c64c9ac9d1f.tar.bz2
aports-a7224fc905a9ef3cf4a94a9581256c64c9ac9d1f.tar.xz
testing/xbindkeys: move from unmaintained
-rw-r--r--testing/xbindkeys/APKBUILD (renamed from unmaintained/xbindkeys/APKBUILD)21
1 files changed, 7 insertions, 14 deletions
diff --git a/unmaintained/xbindkeys/APKBUILD b/testing/xbindkeys/APKBUILD
index 3b32698c3d..4f45ef1839 100644
--- a/unmaintained/xbindkeys/APKBUILD
+++ b/testing/xbindkeys/APKBUILD
@@ -1,5 +1,6 @@
# Contributor: Andrew Hills <ahills@ednos.net>
-# Maintainer: Andrew Hills <ahills@ednos.net>
+# Contributor: Stefan Wagner <stw@bit-strickerei.de>
+# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
pkgname=xbindkeys
pkgver=1.8.6
pkgrel=0
@@ -7,30 +8,22 @@ pkgdesc="Program for launching shell commands via keyboard shortcuts in X"
url="http://www.nongnu.org/xbindkeys/xbindkeys.html"
arch="all"
license="GPL2"
-depends=""
-depends_dev="libx11-dev"
-makedepends="$depends_dev"
-install=
+makedepends="libx11-dev"
subpackages="$pkgname-doc"
source="http://www.nongnu.org/$pkgname/$pkgname-$pkgver.tar.gz"
-
-
-_builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure --prefix=/usr \
--disable-guile \
--mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --build=$CBUILD \
- --host=$CHOST \
- || return 1
+ --infodir=/usr/share/info || return 1
make || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install
}