aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-10-23 16:20:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-23 16:20:06 +0000
commitc36912a4e86aaea180c2a31b9c10943b6a09e0de (patch)
treead3e89b36344ab16811254a1b6a1d68389f070d0
parent337cb0b026ea31673af5cb34871e976fcb4e1dfb (diff)
downloadaports-c36912a4e86aaea180c2a31b9c10943b6a09e0de.tar.bz2
aports-c36912a4e86aaea180c2a31b9c10943b6a09e0de.tar.xz
testing/aspell-en: new aport
English dictionary for aspell http://aspell.net/
-rw-r--r--testing/aspell-en/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/aspell-en/APKBUILD b/testing/aspell-en/APKBUILD
new file mode 100644
index 0000000000..8963220cc7
--- /dev/null
+++ b/testing/aspell-en/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=aspell-en
+pkgver=6.0
+pkgrel=0
+pkgdesc="English dictionary for aspell"
+url="http://aspell.net/"
+license="custom"
+depends="aspell"
+makedepends="aspell-dev"
+source="ftp://ftp.gnu.org/gnu/aspell/dict/en/aspell6-en-$pkgver-0.tar.bz2"
+
+_builddir="$srcdir"/aspell6-en-$pkgver-0
+build () {
+ cd "$_builddir"
+ ./configure || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -D -m644 Copyright \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE || return 1
+}
+
+md5sums="16449e0a266e1ecc526b2f3cd39d4bc2 aspell6-en-6.0-0.tar.bz2"