aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake Buchholz <tomalok@gmail.com>2019-01-10 02:06:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-01-10 09:33:59 +0000
commite3a6a34509c08e45625c940842bdde6bf55af6bc (patch)
tree2bb44e2d94fbd3fa077ddc090aa8641816af31f6
parent3bd24cb5a6f2b8e1bbc27a11c83c861c7e8c9ca5 (diff)
downloadaports-e3a6a34509c08e45625c940842bdde6bf55af6bc.tar.bz2
aports-e3a6a34509c08e45625c940842bdde6bf55af6bc.tar.xz
community/runc: new aport
Splitting runc out of community/docker aport. Also fixing runc --version to report the proper commit hash.
-rw-r--r--community/runc/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/community/runc/APKBUILD b/community/runc/APKBUILD
new file mode 100644
index 0000000000..19e30128fc
--- /dev/null
+++ b/community/runc/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Jake Buchholz <tomalok@gmail.com>
+# Maintainer: Jake Buchholz <tomalok@gmail.com>
+
+pkgname=runc
+
+# NOTE: using explicit post-1.0.0_rc6 commit, for containerd-1.2.1,
+# see https://github.com/containerd/containerd/blob/v1.2.1/RUNC.md
+# and https://github.com/containerd/containerd/blob/v1.2.1/vendor.conf
+_commit=96ec2177ae841256168fcf76954f7177af9446eb
+
+pkgver=1.0.0_rc6
+pkgrel=0
+pkgdesc="CLI tool for spawning and running containers according to the OCI specification"
+url="https://www.opencontainers.org"
+arch="all"
+license="Apache-2.0"
+depends="libseccomp"
+makedepends="go go-md2man libseccomp-dev libtool"
+subpackages="$pkgname-doc"
+source="runc-$_commit.tar.gz::https://github.com/opencontainers/runc/archive/$_commit.tar.gz"
+builddir="$srcdir/src/github.com/opencontainers/runc"
+
+build() {
+ cd "$srcdir"
+ export GOPATH="$PWD"
+ mkdir -p $(dirname "$builddir")
+ ln -s "$PWD/$pkgname-$_commit" "$builddir"
+ cd "$builddir"
+ make COMMIT="$_commit"
+ make man
+}
+
+check() {
+ cd "$builddir"
+ ./runc --version
+}
+
+package() {
+ cd "$builddir"
+ install -Dsm755 "$builddir"/runc "$pkgdir"/usr/bin/runc
+ install -d "$pkgdir"/usr/share/man/man8/
+ install -Dm644 "$builddir"/man/man8/* "$pkgdir"/usr/share/man/man8/
+}
+
+sha512sums="ec3d3fec773f2f9df714b0813efb110e21e328634e0b4ae77f323a892d0327aea5d4b6f9ae2a549aa06fda5b27431f4514fd663c7033dc170ca1a03627931f9d runc-96ec2177ae841256168fcf76954f7177af9446eb.tar.gz"