aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Claus Nunes <maxcnunes@gmail.com>2016-09-29 21:05:07 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-19 15:36:13 +0000
commitc03980ca31c00cde5c00e29b4b264e533430d9ca (patch)
treebae5e97d1a1e01378a89161faf5118a1ae04d13b
parent17c82eb6ba1d81d32e22c7383da06ad1e1fa9bd3 (diff)
downloadaports-c03980ca31c00cde5c00e29b4b264e533430d9ca.tar.bz2
aports-c03980ca31c00cde5c00e29b4b264e533430d9ca.tar.xz
testing/waitforit: new aport
https://github.com/maxcnunes/waitforit A tool written in Golang to wait until an address become available.
-rw-r--r--testing/waitforit/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/waitforit/APKBUILD b/testing/waitforit/APKBUILD
new file mode 100644
index 0000000000..88e4f1d553
--- /dev/null
+++ b/testing/waitforit/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Max Claus Nunes <maxcnunes@gmail.com>
+# Maintainer: Max Claus Nunes <maxcnunes@gmail.com>
+pkgname=waitforit
+pkgver=1.3.2
+pkgrel=0
+pkgdesc="Wait until an address become available"
+url="https://github.com/maxcnunes/waitforit"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev go"
+install=""
+subpackages=""
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/maxcnunes/waitforit/archive/v$pkgver.tar.gz"
+
+builddir="${srcdir}/${pkgname}-${pkgver}"
+_godir="${srcdir}/go"
+_gourl="github.com/maxcnunes/waitforit"
+
+build() {
+ mkdir -p ${_godir}/bin ${_godir}/src/github.com/maxcnunes
+ ln -sf ${builddir} ${_godir}/src/github.com/maxcnunes/waitforit
+
+ cd ${_godir}/src/${_gourl}
+ export GOPATH="${_godir}"
+
+ go get -d -v ./...
+ go install -v ${_gourl} || return 1
+}
+
+package() {
+ cd "$_godir"/bin
+
+ install -Dm755 waitforit \
+ "${pkgdir}/usr/bin/waitforit" || return 1
+}
+
+md5sums="1d7d2d25386cd732c03fb63324ba3d15 waitforit-1.3.2.tar.gz"
+sha256sums="8359692a2f63b5a13e831919f6ac51cf98ec7eb7b6e07038566c5ae21f40abe3 waitforit-1.3.2.tar.gz"
+sha512sums="c50933cab19e160ea591cc2ee7793167b918c7c1dd94fcdf6f70c9744e92ce8287fad1ec135a325fc256fa3af8182d104595829c0627fd956f2a5b50ed2155a6 waitforit-1.3.2.tar.gz"