aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2017-02-07 14:03:21 +0200
committerKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2017-02-07 14:03:41 +0200
commit5938bc9c571af2e1dee1c919b99db90dbccfa1d0 (patch)
treeee8cab43029c8b1925cbd774935891e76439e6fd
parent8fe971d429c58c1e331f3da2efe135484f4755d7 (diff)
downloadaports-5938bc9c571af2e1dee1c919b99db90dbccfa1d0.tar.bz2
aports-5938bc9c571af2e1dee1c919b99db90dbccfa1d0.tar.xz
testing/homer-api: include rotation.ini
-rw-r--r--testing/homer-api/APKBUILD9
-rw-r--r--testing/homer-api/homer-move-config2etc.patch22
2 files changed, 27 insertions, 4 deletions
diff --git a/testing/homer-api/APKBUILD b/testing/homer-api/APKBUILD
index 49070a6d96..4af15b80c0 100644
--- a/testing/homer-api/APKBUILD
+++ b/testing/homer-api/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=homer-api
pkgver=5.0.6
-pkgrel=0
+pkgrel=1
pkgdesc="HOMER API"
url="https://github.com/sipcapture/homer-api"
arch="noarch"
@@ -35,13 +35,14 @@ package() {
"$pkgdir"/etc/homer/configuration.php
install -D -m755 scripts/homer_rotate "$pkgdir"/etc/periodic/daily/homer_rotate
mv scripts/*.pl "$pkgdir"/usr/share/homer-api/scripts
+ install -m644 scripts/rotation.ini "$pkgdir"/etc/homer
cp sql/* "$pkgdir"/usr/share/homer-api/sql
cp -R examples "$pkgdir"/usr/share/doc/homer-api
}
md5sums="16762b9eabfee68a5953b6df87f2c6e6 homer-api-5.0.6.tar.gz
-bf091145599f5f4b0aff1e67992c6ba9 homer-move-config2etc.patch"
+989485384b8c16fcd1f69db8f09d614a homer-move-config2etc.patch"
sha256sums="abe4ab89fe5d0d09d7b89f91316f6ae39a51195903099e73d7dff95d5bd23672 homer-api-5.0.6.tar.gz
-12931c0a5e615fbcda519299d279069a5871d7a38e5c3cdd7eecfae24892f734 homer-move-config2etc.patch"
+d8cdaae740e116d69827ca1e9d7db7284314a83b360a43d8abef6a49ed149c61 homer-move-config2etc.patch"
sha512sums="620185c19bd348ba68bad3a1992b7d673d29dcfb8a0aeea437a2d31e90f0a21cf6f46a43f0041a583a14d9403e1d8574c6040da1dba397ec2d955b8aba9010d8 homer-api-5.0.6.tar.gz
-16cb6e0dab9ad838bac284d8f17b089fd6f1cd5171a92057a494094223094bd65302be46472175e66c741bf00803855e335d7939501aa41799cefc7df88776a0 homer-move-config2etc.patch"
+dcbb488dfad4f30892654ed11eb15cf3b9f1ec3740fad0d0f1811ad3e9e6f30be3c03ce76f366a3a23bf2f9bf3bedf2e5673314552a532115ab0056bb6e9242c homer-move-config2etc.patch"
diff --git a/testing/homer-api/homer-move-config2etc.patch b/testing/homer-api/homer-move-config2etc.patch
index 5bdae0a14d..37bcca0b11 100644
--- a/testing/homer-api/homer-move-config2etc.patch
+++ b/testing/homer-api/homer-move-config2etc.patch
@@ -20,6 +20,28 @@
date_default_timezone_set(HOMER_TIMEZONE);
ini_set('date.timezone', HOMER_TIMEZONE);
+--- homer-api-5.0.6/scripts/homer_mysql_remove_partitions.pl
++++ homer-api-5.0.6.alpine/scripts/homer_mysql_remove_partitions.pl
+@@ -31,7 +31,7 @@
+ $| =1;
+
+ # Determine path and set default rotation.ini location
+-my $script_location = `dirname $0`;
++my $script_location = "/etc/homer";
+ $script_location =~ s/^\s+|\s+$//g;
+ my $default_ini = $script_location."/rotation.ini";
+
+--- homer-api-5.0.6/scripts/homer_mysql_rotate.pl
++++ homer-api-5.0.6.alpine/scripts/homer_mysql_rotate.pl
+@@ -30,7 +30,7 @@
+ $| =1;
+
+ # Determine path and set default rotation.ini location
+-my $script_location = `dirname $0`;
++my $script_location = "/etc/homer";
+ $script_location =~ s/^\s+|\s+$//g;
+ my $default_ini = $script_location."/rotation.ini";
+
--- homer-api-5.0.6/scripts/homer_rotate
+++ homer-api-5.0.6.alpine/scripts/homer_rotate
@@ -3,7 +3,7 @@