aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-04-05 14:27:44 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-04-05 14:30:03 +0000
commitb963814f5bd24d8f74143a0e17cac08fa939992e (patch)
treee66278372e12964bb2640c917c1d9f2ba0e573da
parentfb6c3b6ea852719c54082fb08b618ae62c32142b (diff)
downloadaports-b963814f5bd24d8f74143a0e17cac08fa939992e.tar.bz2
aports-b963814f5bd24d8f74143a0e17cac08fa939992e.tar.xz
testing/alpine-ipxe: upgrade to 1.0_git20180327
-rw-r--r--testing/alpine-ipxe/APKBUILD13
-rw-r--r--testing/alpine-ipxe/boot.ipxe1
2 files changed, 7 insertions, 7 deletions
diff --git a/testing/alpine-ipxe/APKBUILD b/testing/alpine-ipxe/APKBUILD
index b0da130e8b..914bd61f8d 100644
--- a/testing/alpine-ipxe/APKBUILD
+++ b/testing/alpine-ipxe/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=alpine-ipxe
-pkgver=1.0_git20180220
-_sha=47849be3a900c546cf92066849be0806f4e611d9
+pkgver=1.0_git20180327
+_sha=8c17ee115d140ceb509f97158b581cd7a19ee586
pkgrel=2
pkgdesc="iPXE build for Alpine Linux netboot"
url="https://boot.alpinelinux.org"
@@ -39,12 +39,11 @@ done
prepare() {
cd "$builddir"
- local general="NET_PROTO_IPV6 DOWNLOAD_PROTO_HTTPS IMAGE_TRUST_CMD
- PING_CMD REBOOT_CMD"
+ local general="DIGEST_CMD NET_PROTO_IPV6 DOWNLOAD_PROTO_HTTPS IMAGE_TRUST_CMD
+ NSLOOKUP_CMD PING_CMD REBOOT_CMD NTP_CMD PCI_CMD TIME_CMD VLAN_CMD"
mkdir -p config/local
local opt; for opt in $general; do
echo "#define $opt" >> config/local/general.h
- echo "#define $opt" >> config/local/general.h.efi
done
}
@@ -74,7 +73,7 @@ _split() {
"$subpkgdir"/usr/share/$pkgname
}
-sha512sums="abc070ed07970e5307f04f5da3da4916c98016bf0a4115ab04979ecc5e7c452ca5102799ddab926e0ae9867c37c311de785dc93a736bf8f0809d5ea8e3cd3732 ipxe-1.0_git20180220.tar.gz
+sha512sums="60e6696f02d9b1e9e4f82c134ca093862654191f8b9ed969a79e923d03589e35bd964bb11da67362dd1ef4b5aa290844317927ea6f076cd75fec09d78ada1540 ipxe-1.0_git20180327.tar.gz
1f52b62aa9e3ec0656ea3cb5c8e52eda924d58728e64bb03ca6c112858b91b13cf0a9328b105bb232973e240406b240ed14e72b5bd325e82e6fddf3126dbcc58 DST_Root_CA_X3.pem
68030e3f30983ee45c7f740445a246ea0df225becdd0644e06ffdbd84682ac576934dab79fecceb31b70929d81ce85b40301a977862bf7beb042270be21e6d34 alpine-netboot-ca.crt
-5569ba14ed3a164e72edd43e6b9df63fcbc59025c6729f55cbbedf2d513a83075471276a760174432eb2c6da86127a4b68fe1a2cae54408ff53b958261d06f0b boot.ipxe"
+21b0f6fe0604b2a13a0514e74eef1c5af5d311bead5241fd5da8e3d76bfbaaed02d5517bd446a33f5642ff9ec6f20de73493b0cb3dd13692484076da9b6c4fde boot.ipxe"
diff --git a/testing/alpine-ipxe/boot.ipxe b/testing/alpine-ipxe/boot.ipxe
index ba2c2a5a8b..9434db43c9 100644
--- a/testing/alpine-ipxe/boot.ipxe
+++ b/testing/alpine-ipxe/boot.ipxe
@@ -1,3 +1,4 @@
#!ipxe
ifconf
chain https://boot.alpinelinux.org/boot.ipxe || shell
+exit