aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-11-27 13:23:57 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-27 14:10:03 +0100
commit308944d90df71c773c958a1c5ff4ebdb240526a3 (patch)
tree88f1668824f4f80c5d21c31e954d9f847144c1d9
parent7d73d222fd7122c6881d333ea7d07fc500596495 (diff)
downloadaports-308944d90df71c773c958a1c5ff4ebdb240526a3.tar.bz2
aports-308944d90df71c773c958a1c5ff4ebdb240526a3.tar.xz
main/nodejs: rename to nodejs-current and move to community
Odd-numbered versions, like this one (v7), are supported by upstream only for 9 months. When a new odd-numbered major release is cut, the previous even-numbered major version transitions to the Long Term Support plan (LTS). Packages in Alpine stable must be supported for 2 years, so we should keep only LTS version in the stable. Therefore this package is renamed to nodejs-current and moved to the community repository. The nodejs-lts package is going to be renamed to nodejs. See https://github.com/nodejs/LTS#lts-schedule
-rw-r--r--community/nodejs-current/APKBUILD (renamed from main/nodejs/APKBUILD)7
-rw-r--r--community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch (renamed from main/nodejs/dont-run-gyp-files-for-bundled-deps.patch)0
-rw-r--r--community/nodejs-current/use-system-ca-certs.patch (renamed from main/nodejs/use-system-ca-certs.patch)0
3 files changed, 4 insertions, 3 deletions
diff --git a/main/nodejs/APKBUILD b/community/nodejs-current/APKBUILD
index 292efebbcb..93acc75c3e 100644
--- a/main/nodejs/APKBUILD
+++ b/community/nodejs-current/APKBUILD
@@ -1,9 +1,10 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jose-Luis Rivas <ghostbar@riseup.net>
-pkgname=nodejs
+pkgname=nodejs-current
+# The current stable version, i.e. non-LTS.
pkgver=7.2.0
pkgrel=0
-pkgdesc="JavaScript runtime built on V8 engine"
+pkgdesc="JavaScript runtime built on V8 engine - current stable version"
url="http://nodejs.org/"
arch="all"
license="MIT"
@@ -12,7 +13,7 @@ depends_dev="libuv"
makedepends="$depends_dev python2 openssl-dev zlib-dev libuv-dev linux-headers
paxmark binutils-gold http-parser-dev ca-certificates"
subpackages="$pkgname-dev $pkgname-doc"
-replaces="nodejs-lts"
+replaces="nodejs nodejs-lts" # nodejs-lts for backward compatibility
source="https://nodejs.org/dist/v$pkgver/node-v$pkgver.tar.gz
use-system-ca-certs.patch
dont-run-gyp-files-for-bundled-deps.patch"
diff --git a/main/nodejs/dont-run-gyp-files-for-bundled-deps.patch b/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch
index ba521dc4fc..ba521dc4fc 100644
--- a/main/nodejs/dont-run-gyp-files-for-bundled-deps.patch
+++ b/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch
diff --git a/main/nodejs/use-system-ca-certs.patch b/community/nodejs-current/use-system-ca-certs.patch
index 6e46c74b40..6e46c74b40 100644
--- a/main/nodejs/use-system-ca-certs.patch
+++ b/community/nodejs-current/use-system-ca-certs.patch