aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-20 16:51:26 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-20 16:51:26 -0300
commit096128fc2fe75dcd2f00b82ef08083a3be9cff4d (patch)
treef80989b9d8dd3034a0c79901195c6bb56ea4bbf2
parentd5bdd5bb2b87e2ac46277bf82150b289031fcc39 (diff)
downloadaports-096128fc2fe75dcd2f00b82ef08083a3be9cff4d.tar.bz2
aports-096128fc2fe75dcd2f00b82ef08083a3be9cff4d.tar.xz
testing/py3-django-timezone-field: switch to py3
-rw-r--r--testing/py3-django-timezone-field/APKBUILD51
1 files changed, 13 insertions, 38 deletions
diff --git a/testing/py3-django-timezone-field/APKBUILD b/testing/py3-django-timezone-field/APKBUILD
index d31ff66362..5adb86e19b 100644
--- a/testing/py3-django-timezone-field/APKBUILD
+++ b/testing/py3-django-timezone-field/APKBUILD
@@ -1,55 +1,30 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer:
-pkgname=py-django-timezone-field
+pkgname=py3-django-timezone-field
+_pkgname=django-timezone-field
pkgver=3.0
-pkgrel=1
+pkgrel=2
pkgdesc="A Django app providing database and form fields for pytz timezone objects"
+options="!check" # Testsuite is only coverage and flake8 tests
url="https://pypi.python.org/pypi/django-timezone-field"
arch="noarch"
-license="BSD"
-depends="py-django py-tz"
-makedepends="python2-dev python3-dev py-setuptools"
-options="!check" #no testsuite
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="$pkgname-$pkgver.tar.gz::https://github.com/mfogel/django-timezone-field/archive/$pkgver.tar.gz"
-builddir="$srcdir"/django-timezone-field-$pkgver
+license="BSD-2-Clause"
+depends="py3-django py3-tz"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mfogel/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
- python2 setup.py --quiet build
- python3 setup.py --quiet build
-}
+ python3 setup.py build
-package() {
- cd "$builddir"
- mkdir -p "$pkgdir"/usr/bin
}
check() {
- cd "$builddir"
- python2 tests.py
python3 tests.py
}
-_py2() {
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- local pyver="${1:6:1}"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+package() {
+ python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
}
-sha512sums="00e2df498674c151d53581e0dd8bb5e775d595113a12bfba127d558de1f1b31003fffaa070645a9601266bd2bfe59511e493d0dbcf30e624411a9ff7867d9341 py-django-timezone-field-3.0.tar.gz"
+sha512sums="00e2df498674c151d53581e0dd8bb5e775d595113a12bfba127d558de1f1b31003fffaa070645a9601266bd2bfe59511e493d0dbcf30e624411a9ff7867d9341 py3-django-timezone-field-3.0.tar.gz"