aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-04-16 08:40:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-17 11:45:44 +0000
commit194863bbdd81667d94fb476a74d6f785fa1ea8d9 (patch)
tree2b72c9ee965e3594a844cf7237f56920c6b8a955
parent1d0c01530bd7a40b24bb246ce869d79083e23b3c (diff)
downloadaports-194863bbdd81667d94fb476a74d6f785fa1ea8d9.tar.bz2
aports-194863bbdd81667d94fb476a74d6f785fa1ea8d9.tar.xz
community/python3-tkinter: upgrade to 3.7.3
-rw-r--r--community/python3-tkinter/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/community/python3-tkinter/APKBUILD b/community/python3-tkinter/APKBUILD
index 1f03d8e270..c1a322ae19 100644
--- a/community/python3-tkinter/APKBUILD
+++ b/community/python3-tkinter/APKBUILD
@@ -2,9 +2,9 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
pkgname=python3-tkinter
-pkgver=3.6.8
+pkgver=3.7.3
_basever="${pkgver%.*}"
-pkgrel=1
+pkgrel=0
pkgdesc="A graphical user interface for the Python"
url="https://wiki.python.org/moin/TkInter"
arch="all"
@@ -15,7 +15,6 @@ makedepends="expat-dev openssl-dev zlib-dev ncurses-dev bzip2-dev xz-dev
sqlite-dev libffi-dev tcl-dev linux-headers gdbm-dev readline-dev
tk tk-dev python3"
source="https://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.xz
- CVE-2019-5010.patch
musl-find_library.patch
fix-xattrs-glibc.patch
"
@@ -26,7 +25,7 @@ builddir="$srcdir/Python-$pkgver"
# - CVE-2019-5010
prepare() {
- local _pyapkbuild="$startdir"/../python3/APKBUILD
+ local _pyapkbuild="$startdir"/../../main/python3/APKBUILD
if [ -e "$_pyapkbuild" ]; then
_pver=$(. "$_pyapkbuild" ; echo $pkgver)
if [ "$_pver" != "$pkgver" ]; then
@@ -39,7 +38,6 @@ prepare() {
# force system libs
rm -r Modules/expat \
- Modules/zlib \
Modules/_ctypes/darwin* \
Modules/_ctypes/libffi*
}
@@ -66,7 +64,9 @@ build() {
--with-system-ffi \
--with-threads
- make EXTRA_CFLAGS="$CFLAGS"
+ # set thread stack size to 1MB so we don't segfault before we hit
+ # sys.getrecursionlimit()
+ make EXTRA_CFLAGS="$CFLAGS -DTHREAD_STACK_SIZE=0x100000"
}
package() {
@@ -103,7 +103,7 @@ tests() {
replaces="python3-tests"
cd "$pkgdir"
_mv_files usr/lib/python*/*/*_test \
- usr/lib/python3.6/tkinter/test
+ usr/lib/python${pkgver%.*}/tkinter/test
}
_idle() {
@@ -115,7 +115,6 @@ _idle() {
_mv_files usr/lib/python*/idlelib
}
-sha512sums="b17867e451ebe662f50df83ed112d3656c089e7d750651ea640052b01b713b58e66aac9e082f71fd16f5b5510bc9b797f5ccd30f5399581e9aa406197f02938a Python-3.6.8.tar.xz
-7859fe12e393995f66f42e38f01ff29abef5f64301747a02d8e49a990ce4e7f529cf2a3420c76bd5f9df09905e64a4e0451a2103c061dde5f99166e7fc370715 CVE-2019-5010.patch
+sha512sums="6d9b7c0f1764e0f655a39430a3af6f7b5e3c9b7166c042e780677a54b17ad4ca6d0d9cba262c82b1b70bba8f7c28883dad4cc0d7cc194fc7d2c1b5f4f08a763a Python-3.7.3.tar.xz
ab8eaa2858d5109049b1f9f553198d40e0ef8d78211ad6455f7b491af525bffb16738fed60fc84e960c4889568d25753b9e4a1494834fea48291b33f07000ec2 musl-find_library.patch
37b6ee5d0d5de43799316aa111423ba5a666c17dc7f81b04c330f59c1d1565540eac4c585abe2199bbed52ebe7426001edb1c53bd0a17486a2a8e052d0f494ad fix-xattrs-glibc.patch"