aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanct12 <danct12@disroot.org>2019-10-10 08:30:44 +0700
committerKevin Daudt <kdaudt@alpinelinux.org>2019-10-11 16:14:27 +0000
commit442cde8100b6ab7613bcf1b588a3a2552006dbeb (patch)
tree30fbf09af56f7138cc163a9479284b51cf4a0932
parent2de962b640bd557952c0e228cd7f605082e04898 (diff)
downloadaports-442cde8100b6ab7613bcf1b588a3a2552006dbeb.tar.bz2
aports-442cde8100b6ab7613bcf1b588a3a2552006dbeb.tar.xz
testing/wf-config: new aport
Signed-off-by: Danct12 <danct12@disroot.org> Closes GH-11873
-rw-r--r--testing/wf-config/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/wf-config/APKBUILD b/testing/wf-config/APKBUILD
new file mode 100644
index 0000000000..b2ceb05583
--- /dev/null
+++ b/testing/wf-config/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Danct12 <danct12@disroot.org>
+# Maintainer: Danct12 <danct12@disroot.org>
+pkgname=wf-config
+pkgver=0.3
+pkgrel=0
+pkgdesc="Library for managing configuration files written for Wayfire"
+url="https://wayfire.org"
+arch="all"
+license="MIT"
+makedepends="libevdev-dev wlroots-dev meson ninja"
+options="!check" # no testsuite
+subpackages="$pkgname-dev"
+
+# Source
+source="https://github.com/WayfireWM/wf-config/releases/download/$pkgver/wf-config-$pkgver.tar.xz"
+
+build() {
+ meson build --prefix=/usr --buildtype=release
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}
+
+sha512sums="b0df9735583c0665fb2fdd2353dbce07e11239eb26fd080159c7f386dba9b370d7908b09504bafde1e11f45be95adc128466017c45e9fcd75a0dea00af70d741 wf-config-0.3.tar.xz"