aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2015-05-09 20:06:26 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2015-05-21 14:12:49 +0000
commit47c75ab3b15c6524f22fb84d00f8b3f56aaa427a (patch)
tree1a3c2aaebafdbf803b04edbc150ce0d36b72ff5e
parentb9a31889d838ff684b09e7d9644836d77554e349 (diff)
downloadaports-47c75ab3b15c6524f22fb84d00f8b3f56aaa427a.tar.bz2
aports-47c75ab3b15c6524f22fb84d00f8b3f56aaa427a.tar.xz
testing/udevil: move post-install message
post-install message moved to $pkgname/usr/share/doc/README.alpine
-rw-r--r--testing/udevil/APKBUILD31
-rw-r--r--testing/udevil/udevil.apk-post-msg11
2 files changed, 20 insertions, 22 deletions
diff --git a/testing/udevil/APKBUILD b/testing/udevil/APKBUILD
index 95257a22b6..2665db0c60 100644
--- a/testing/udevil/APKBUILD
+++ b/testing/udevil/APKBUILD
@@ -9,11 +9,9 @@ arch="all"
license="GPL3+"
makedepends="$depends_dev glib-dev udev-dev intltool"
install="$pkgname.pre-install"
-subpackages="$pkgname-lang"
+subpackages="$pkgname-lang $pkgname-doc"
pkggroups="plugdev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/IgnorantGuru/$pkgname/archive/$pkgver.tar.gz
- $pkgname.apk-post-msg
- "
+source="$pkgname-$pkgver.tar.gz::https://github.com/IgnorantGuru/$pkgname/archive/$pkgver.tar.gz"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -40,13 +38,24 @@ package() {
chown root:plugdev "$pkgdir"/usr/bin/udevil || return 1
chmod u+s,go-s,o-x "$pkgdir"/usr/bin/udevil # remove SUID bit
mkdir -p "$pkgdir/usr/share/apk-tools/$pkgname"
- install -m644 "$srcdir/$pkgname.apk-post-msg" "$pkgdir/usr/share/apk-tools/$pkgname/post-install-message" || return 1
# chmod ugo-s,ugo+x "$pkgdir"/usr/bin/udevil #remove SUID bit completely
+ # post-install message
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname"
+ cat > $pkgdir/usr/share/doc/$pkgname/README.alpine <<EOF
+To mount / unmount devices without the root password: add your user account to the 'plugdev' group.
+
+Optional dependencies:
+
+zenity: (devmon popups)
+davfs2: (mount WebDAV resources)
+cifs-utils: (mounting samba shares)
+curlftpfs: (mounting ftp shares)
+nfs-utils: (mounting nfs shares)
+sshfs-fuse: (mounting sftp shares)
+eject: (eject via devmon)
+EOF
}
-md5sums="281aa065d92c679cb41728069e72b272 udevil-0.4.4.tar.gz
-cd426d9d4f6387eb6eca51c661525d1b udevil.apk-post-msg"
-sha256sums="ad2fd8375bd62622718a04235e9772119459089938dbb78e657955e595822b7c udevil-0.4.4.tar.gz
-be09f2c03a852eee3e2b94250664e8a63b33df631a098e500d730a56c839789a udevil.apk-post-msg"
-sha512sums="adce4916e06d1cc4965521abbcbc2901e53930691167f431cb18e28d3ef8bde740e95a6a5f40dfc58dfd7b4b661b4475d3dd2b6174a5d7a55ae7c65629b82327 udevil-0.4.4.tar.gz
-060e17a1847a40f5ad1f19d803c14de8be2bcde205cf23fbbd73f0167c577f4be04749476e31e6e153033f0b92a70b264b553bb4cc3c077acdb39b117a0f9814 udevil.apk-post-msg"
+md5sums="281aa065d92c679cb41728069e72b272 udevil-0.4.4.tar.gz"
+sha256sums="ad2fd8375bd62622718a04235e9772119459089938dbb78e657955e595822b7c udevil-0.4.4.tar.gz"
+sha512sums="adce4916e06d1cc4965521abbcbc2901e53930691167f431cb18e28d3ef8bde740e95a6a5f40dfc58dfd7b4b661b4475d3dd2b6174a5d7a55ae7c65629b82327 udevil-0.4.4.tar.gz"
diff --git a/testing/udevil/udevil.apk-post-msg b/testing/udevil/udevil.apk-post-msg
deleted file mode 100644
index 6c63d7e4d9..0000000000
--- a/testing/udevil/udevil.apk-post-msg
+++ /dev/null
@@ -1,11 +0,0 @@
-To mount / unmount devices without the root password: add your user account to the 'plugdev' group.
-
-Optional dependencies:
-
-zenity: (devmon popups)
-davfs2: (mount WebDAV resources)
-cifs-utils: (mounting samba shares)
-curlftpfs: (mounting ftp shares)
-nfs-utils: (mounting nfs shares)
-sshfs-fuse: (mounting sftp shares)
-eject: (eject via devmon)