aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-30 16:52:22 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-30 17:01:35 +0100
commit4ccb0bc9ab11157b0dafa238363df23bb37957fd (patch)
tree24e35b42463fc5adffadb35571a14591a84af87c
parentdbaf77aee1af6f6df1758e3e6562e59e1b1b3b4c (diff)
downloadaports-4ccb0bc9ab11157b0dafa238363df23bb37957fd.tar.bz2
aports-4ccb0bc9ab11157b0dafa238363df23bb37957fd.tar.xz
main/open-isns: upgrade to 0.99
-rw-r--r--main/open-isns/APKBUILD17
-rw-r--r--main/open-isns/musl-fixes.patch21
2 files changed, 6 insertions, 32 deletions
diff --git a/main/open-isns/APKBUILD b/main/open-isns/APKBUILD
index cea1171ad7..19e0eb4aa9 100644
--- a/main/open-isns/APKBUILD
+++ b/main/open-isns/APKBUILD
@@ -1,28 +1,24 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=open-isns
-pkgver=0.97
-pkgrel=4
+pkgver=0.99
+pkgrel=0
pkgdesc="iSNS server and client for Linux"
url="https://github.com/open-iscsi/open-isns"
arch="all"
-license="LGPL-2.0"
+license="LGPL-2.1-or-later"
makedepends="autoconf automake openssl-dev musl-dev"
options="!check"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lib"
source="$pkgname-$pkgver.tar.gz::https://github.com/open-iscsi/open-isns/archive/v$pkgver.tar.gz
- musl-fixes.patch
"
-builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$builddir"
default_prepare
update_config_sub
- autoconf && autoheader
+ autoreconf -fi
}
build() {
- cd "$builddir"
./configure \
--host=$CHOST \
--build=$CBUILD \
@@ -35,11 +31,11 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
make DESTDIR="$pkgdir" install_hdrs
make DESTDIR="$pkgdir" install_lib
rm -rf "$pkgdir"/usr/lib/systemd
+ rm -rf "$pkgdir"/usr/lib/*.a
}
lib() {
@@ -48,5 +44,4 @@ lib() {
mv "$pkgdir"/usr/lib "$subpkgdir"/usr
}
-sha512sums="78c934162d5a1d093bccd49449d4ef369b896d34309d76b4963d643a699640617c4fe064388c481c35b9be26e012f19713f3aad378af9ad88fa94c3d300e919d open-isns-0.97.tar.gz
-14eb43b8659c4c917fb35f2e33bffb90c7288555c3feb1ba4afd502c3e509bb44d0ad91b6c4ef09c68cd30eb812df11440a1c28720ee9be8cf4af6c0d8d6dc8d musl-fixes.patch"
+sha512sums="90a2297535c5e939f83c761173ce5f5f88e68adc31e41e833b23d07b6dc6959572ae7184db0084b861918199a877b251ebae4b4a7456fdd8c93400dc8457adc9 open-isns-0.99.tar.gz"
diff --git a/main/open-isns/musl-fixes.patch b/main/open-isns/musl-fixes.patch
deleted file mode 100644
index 1cd5d13f26..0000000000
--- a/main/open-isns/musl-fixes.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/include/libisns/util.h
-+++ b/include/libisns/util.h
-@@ -100,7 +100,7 @@
- * There's no htonll yet
- */
- #ifndef htonll
--# ifdef __GLIBC__
-+# ifdef __linux__
- # include <endian.h>
- # include <byteswap.h>
- # if __BYTE_ORDER == __BIG_ENDIAN
---- a/include/libisns/isns.h
-+++ b/include/libisns/isns.h
-@@ -13,6 +13,7 @@
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <stdio.h>
-+#include <time.h>
-
- #include <libisns/isns-proto.h>
- #include <libisns/types.h>