aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-05-04 09:47:30 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-05-04 18:55:52 +0000
commit5baa9cdc509869a84ae53d2138c071bc28315561 (patch)
tree2d571a8c513815ef218fae8de2986398a3f17447
parent7dfd029b4feaf02d44b28d5e6d3e7338e747fda2 (diff)
downloadaports-5baa9cdc509869a84ae53d2138c071bc28315561.tar.bz2
aports-5baa9cdc509869a84ae53d2138c071bc28315561.tar.xz
community/fd: fix packaging
-rw-r--r--community/fd/APKBUILD39
1 files changed, 10 insertions, 29 deletions
diff --git a/community/fd/APKBUILD b/community/fd/APKBUILD
index 954a9b1a1b..189fd9072c 100644
--- a/community/fd/APKBUILD
+++ b/community/fd/APKBUILD
@@ -12,9 +12,10 @@ checkdepends="coreutils"
options="net"
subpackages="
$pkgname-doc
- $pkgname-bash-completion:bashcomp:noarch
- $pkgname-zsh-compltion:zshcomp:noarch
- $pkgname-fish-completion:fishcomp:noarch"
+ $pkgname-bash-completion
+ $pkgname-zsh-completion
+ $pkgname-fish-completion
+ "
source="$pkgname-$pkgver.tar.gz::https://github.com/sharkdp/fd/archive/v$pkgver.tar.gz"
build() {
@@ -29,32 +30,12 @@ package() {
cargo install --path . --root="$pkgdir"/usr
rm "$pkgdir"/usr/.crates.toml "$pkgdir"/usr/.crates2.json
install -Dm644 doc/fd.1 "$pkgdir"/usr/share/man/man1/fd.1
-}
-
-bashcomp() {
- depends=""
- pkgdesc="Bash completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
-
- install -Dm644 "$builddir"/target/release/build/fd-find-*/out/fd.bash \
- "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
-}
-
-zshcomp() {
- depends=""
- pkgdesc="Zsh completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel zsh"
-
- install -Dm644 "$builddir"/target/release/build/fd-find-*/out/_fd \
- "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
-}
-
-fishcomp() {
- depends=""
- pkgdesc="Fish completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel fish"
- install -Dm644 "$builddir"/target/release/build/fd-find-*/out/fd.fish \
- "$subpkgdir"/usr/share/fish/completions/fd.fish
+ find "$builddir"/target/release/build/fd-find-* -type f -iname fd.bash \
+ -exec install -Dm644 '{}' "$pkgdir"/usr/share/bash-completion/completions/fd \;
+ find "$builddir"/target/release/build/fd-find-* -type f -iname _fd \
+ -exec install -Dm644 '{}' "$pkgdir"/usr/share/zsh/site-functions/_fd \;
+ find "$builddir"/target/release/build/fd-find-* -type f -iname fd.fish \
+ -exec install -Dm644 '{}' "$pkgdir"/usr/share/fish/completions/fd.fish \;
}
sha512sums="01f7caee8edd7ce45bdcc041dd39b4adc58d89750ea7de624911b0a64a303269f588356a4ffe64f27fe04527970b7eef1e4f31f6c4f36eec349af6df9ce74800 fd-8.0.0.tar.gz"