aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-10-04 09:44:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-06 21:35:08 +0200
commit5fe8f482113aabe5064d5a9396f0a7ff277941f0 (patch)
tree29d7ec1228fb576cf17d4119d32202675e7a626e
parent5fccdf04594f5f66bc11f05be3a59c6002f6bf38 (diff)
downloadaports-5fe8f482113aabe5064d5a9396f0a7ff277941f0.tar.bz2
aports-5fe8f482113aabe5064d5a9396f0a7ff277941f0.tar.xz
main/libressl: move to main and add version to subpackages
we want be able to have multiple versions of libs installed in parallel to make upgrades easier in future.
-rw-r--r--main/libressl/APKBUILD (renamed from testing/libressl/APKBUILD)11
1 files changed, 6 insertions, 5 deletions
diff --git a/testing/libressl/APKBUILD b/main/libressl/APKBUILD
index 5cfc405cb7..2998083483 100644
--- a/testing/libressl/APKBUILD
+++ b/main/libressl/APKBUILD
@@ -3,16 +3,17 @@
# Maintainer: Orion <systmkor@gmail.com>
pkgname=libressl
pkgver=2.4.3
-pkgrel=0
+_namever=${pkgname}${pkgver%.*}
+pkgrel=1
pkgdesc="Version of the TLS/crypto stack forked from OpenSSL"
url="http://www.libressl.org/"
arch="all"
license="custom"
-depends="$pkgname-libcrypto=$pkgver-r$pkgrel $pkgname-libssl=$pkgver-r$pkgrel"
+depends=""
makedepends="linux-headers"
replaces="openssl"
-subpackages="$pkgname-libcrypto:_libs $pkgname-libssl:_libs $pkgname-libtls:_libs
- $pkgname-dev $pkgname-doc"
+subpackages="$_namever-libcrypto:_libs $_namever-libssl:_libs
+ $_namever-libtls:_libs $pkgname-dev $pkgname-doc"
source="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
@@ -41,7 +42,7 @@ dev() {
}
_libs() {
- local name="${subpkgname#$pkgname-}"
+ local name="${subpkgname#$_namever-}"
pkgdesc="libressl $name library"
depends=""