aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorinfo@mobile-stream.com <info@mobile-stream.com>2018-11-26 22:05:44 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-30 12:48:49 +0000
commit6de784e835e267c4eb4b0c1e995fb27e213241b3 (patch)
tree1b24dc8a16e09a46887883175e3a1fb709983ec9
parent870acc25ca1d36706c9928eb5ce6051f3194aeb9 (diff)
downloadaports-6de784e835e267c4eb4b0c1e995fb27e213241b3.tar.bz2
aports-6de784e835e267c4eb4b0c1e995fb27e213241b3.tar.xz
main/faac: fix build with gcc8 (useful -Werror)
gcc8 reports meaningful -Wpointer-compare case in common/mp4v2/rtphint.cpp:345 however fixing it directly will enable previously unused code block. This may be dangerous since the bundled mp4v2 library is *very* old and there is no test suite. Moreover, upstream no longer ships mp4v2 at all in faac-1.29+. So just pass -fpermissive in CXXFLAGS for now to avoid any behaviour changes. This work-around should be removed on faac upgrade or proper fix.
-rw-r--r--main/faac/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/main/faac/APKBUILD b/main/faac/APKBUILD
index f9267b453e..23fedfbae2 100644
--- a/main/faac/APKBUILD
+++ b/main/faac/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=faac
pkgver=1.28
-pkgrel=11
+pkgrel=12
pkgdesc="FAAC is an AAC audio encoder."
url="http://www.audiocoding.com/"
arch="all"
@@ -34,6 +34,7 @@ prepare() {
build() {
cd "$srcdir"/$pkgname-$pkgver
+ CXXFLAGS="$CXXFLAGS -fpermissive" \
./configure \
--build=$CBUILD \
--host=$CHOST \