aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-09-05 10:35:09 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-09-05 10:35:09 +0000
commit76b2e292318ca1073db7adc15c8e96e55205d91e (patch)
tree934fd1c3d5d2e9a51fc46c815dce423c9b69819b
parente00e16099a38ec65830e33a34f8812bc193cb23b (diff)
downloadaports-76b2e292318ca1073db7adc15c8e96e55205d91e.tar.bz2
aports-76b2e292318ca1073db7adc15c8e96e55205d91e.tar.xz
community/py-bottle: upgrade to 0.12.9, moved from testing,added python3 support, added py2 and py3 subpackages
-rw-r--r--community/py-bottle/APKBUILD50
-rw-r--r--testing/py-bottle/APKBUILD41
2 files changed, 50 insertions, 41 deletions
diff --git a/community/py-bottle/APKBUILD b/community/py-bottle/APKBUILD
new file mode 100644
index 0000000000..818b991387
--- /dev/null
+++ b/community/py-bottle/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Paul Kilar <pkilar@gmail.com>
+# Maintainer: Paul Kilar <pkilar@gmail.com>
+pkgname=py-bottle
+_pkgname=bottle
+pkgver=0.12.9
+pkgrel=0
+pkgdesc="A fast, simple and lightweight WSGI micro web-framework"
+url="http://bottlepy.org/"
+arch="noarch"
+license="MIT"
+depends=""
+makedepends="python2-dev py-setuptools python3-dev"
+install=""
+subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python=$1
+ pkgdesc="$pkgdesc - $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ _py python2
+ replaces="$pkgname"
+}
+
+_py3() {
+ _py python3
+}
+
+
+
+md5sums="f5850258a86224a791171e8ecbb66d99 bottle-0.12.9.tar.gz"
+sha256sums="fe0a24b59385596d02df7ae7845fe7d7135eea73799d03348aeb9f3771500051 bottle-0.12.9.tar.gz"
+sha512sums="c11d3cb916a0912dcda953a25b9e3a4c6f8e68e31bbaba653f1cae0e12f6b6d827fcbc9d1dfbdb9af2e28276b0056a31fa863d3723a709911406f426d528840b bottle-0.12.9.tar.gz"
diff --git a/testing/py-bottle/APKBUILD b/testing/py-bottle/APKBUILD
deleted file mode 100644
index d6b88ee715..0000000000
--- a/testing/py-bottle/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Paul Kilar <pkilar@gmail.com>
-# Maintainer: Paul Kilar <pkilar@gmail.com>
-pkgname=py-bottle
-_pkgname=bottle
-pkgver=0.12.8
-pkgrel=0
-pkgdesc="A fast, simple and lightweight WSGI micro web-framework"
-url="http://bottlepy.org/"
-arch="noarch"
-license="MIT"
-depends="python"
-depends_dev=""
-makedepends=""
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="13132c0a8f607bf860810a6ee9064c5b bottle-0.12.8.tar.gz"
-sha256sums="cd5d1755a85e533205ed8a2465badf38602227c5f171c3852e07724b28c050ac bottle-0.12.8.tar.gz"
-sha512sums="85fbdac6f7ae804a74bc527bb47bcdb5cf653a0227efe36e81e25513b687dd4abc1f772ff7232bd914cb392dea07297154d80aa05b1216c1f796dbed0d5a9510 bottle-0.12.8.tar.gz"