aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2019-04-30 16:55:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-01 06:46:06 +0000
commit9cc71260d92d18d2266f4083c10468df59c6f0b0 (patch)
treeb6e03cefaa95d6808f2bb67fdc7c023a2389f068
parentee3c34d4222ffb77de423b36ae4f0035a1b008e0 (diff)
downloadaports-9cc71260d92d18d2266f4083c10468df59c6f0b0.tar.bz2
aports-9cc71260d92d18d2266f4083c10468df59c6f0b0.tar.xz
main/hexchat: fix intermittant build errors by forcing build dependancy order
-rw-r--r--main/hexchat/APKBUILD6
-rw-r--r--main/hexchat/force-meson-build-order.patch11
2 files changed, 15 insertions, 2 deletions
diff --git a/main/hexchat/APKBUILD b/main/hexchat/APKBUILD
index 654204fa5f..920dbe6226 100644
--- a/main/hexchat/APKBUILD
+++ b/main/hexchat/APKBUILD
@@ -11,7 +11,8 @@ makedepends="dbus-glib-dev gtk+2.0-dev iso-codes libnotify-dev libproxy-dev
openssl-dev libsexy-dev libxml2-dev lua5.3-dev meson python3-dev"
install=""
subpackages="$pkgname-doc $pkgname-lang $pkgname-python:_python"
-source="https://dl.hexchat.net/$pkgname/$pkgname-$pkgver.tar.xz"
+source="https://dl.hexchat.net/$pkgname/$pkgname-$pkgver.tar.xz
+ force-meson-build-order.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -41,4 +42,5 @@ _python() {
"$subpkgdir"/usr/lib/hexchat/plugins
}
-sha512sums="488799700e439a137ad469f618cb1abf75d1f1ebf223c750d658004ef7b2c728543a5a9ae4e6317d6447428dc59e12dded619346a5d8bba12c92dab653512fca hexchat-2.14.2.tar.xz"
+sha512sums="488799700e439a137ad469f618cb1abf75d1f1ebf223c750d658004ef7b2c728543a5a9ae4e6317d6447428dc59e12dded619346a5d8bba12c92dab653512fca hexchat-2.14.2.tar.xz
+f579622330391fbce798bf9b0e5c1d07975a188b79f7160ab8c921b7df92b2d31444f30d6f62b7b08f7543a4ef40975ecf53705903374b73069bb369967491c5 force-meson-build-order.patch"
diff --git a/main/hexchat/force-meson-build-order.patch b/main/hexchat/force-meson-build-order.patch
new file mode 100644
index 0000000000..be0c72a6f1
--- /dev/null
+++ b/main/hexchat/force-meson-build-order.patch
@@ -0,0 +1,11 @@
+--- a/src/fe-gtk/meson.build
++++ b/src/fe-gtk/meson.build
+@@ -86,7 +86,7 @@
+
+ executable('hexchat',
+ sources: resources + hexchat_gtk_sources,
+- dependencies: hexchat_gtk_deps,
++ dependencies: [hexchat_gtk_deps,declare_dependency(sources: textevents)],
+ c_args: hexchat_gtk_cflags,
+ link_args: hexchat_gtk_ldflags,
+ install: true,