aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-03-02 19:36:22 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-03 02:25:14 -0300
commita35a2d9577303ea40f72917906d377ef584984ba (patch)
treeba9c8d3d0b3b11b94aa4fc6da2f097a81050522f
parent798783b3eae7bb5e85440f70408e1ea09d222b97 (diff)
downloadaports-a35a2d9577303ea40f72917906d377ef584984ba.tar.bz2
aports-a35a2d9577303ea40f72917906d377ef584984ba.tar.xz
testing/py3-evohome-client: enable tests
-rw-r--r--testing/py3-evohome-client/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/testing/py3-evohome-client/APKBUILD b/testing/py3-evohome-client/APKBUILD
index b0360958db..53d228ed03 100644
--- a/testing/py3-evohome-client/APKBUILD
+++ b/testing/py3-evohome-client/APKBUILD
@@ -4,12 +4,12 @@ pkgname=py3-evohome-client
pkgver=0.3.3
pkgrel=1
pkgdesc="Python client to access the Evohome web service"
-options="!check" # Requires unpackaged requests-mock
url="https://github.com/watchforstock/evohome-client"
arch="noarch"
license="Apache-2.0"
depends="python3 py3-requests"
makedepends="py3-setuptools"
+checkdepends="py3-nose py3-requests-mock"
source="evohome-client-$pkgver.tar.gz::https://github.com/watchforstock/evohome-client/archive/$pkgver.tar.gz"
builddir="$srcdir"/evohome-client-$pkgver
@@ -20,6 +20,11 @@ build() {
python3 setup.py build
}
+check() {
+ mkdir test-reports
+ nosetests
+}
+
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}