aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2019-05-12 15:21:44 +0100
committerprspkt <prspkt@protonmail.com>2019-06-21 02:06:05 +0300
commitb6d0057e2efd720dbf0d4c59273dd90fd0d97948 (patch)
tree4de5e706b7fb19c07883508196c7b1a4aa4aa448
parent0a335fe4834b5b4a2e7603d62c2144ddb43de02e (diff)
downloadaports-b6d0057e2efd720dbf0d4c59273dd90fd0d97948.tar.bz2
aports-b6d0057e2efd720dbf0d4c59273dd90fd0d97948.tar.xz
community/py3-google-auth-httplib2: new aport
Dependency for community/goobook
-rw-r--r--community/py3-google-auth-httplib2/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/py3-google-auth-httplib2/APKBUILD b/community/py3-google-auth-httplib2/APKBUILD
new file mode 100644
index 0000000000..f76fd78777
--- /dev/null
+++ b/community/py3-google-auth-httplib2/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
+# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
+pkgname=py3-google-auth-httplib2
+_pyname=google-auth-httplib2
+pkgver=0.0.3
+pkgrel=0
+pkgdesc="Google Authentication Library: httplib2 transport"
+url="https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-google-auth py3-httplib2 py3-six"
+checkdepends="py3-flask py3-mock py3-pytest py3-pytest-localserver"
+source="https://files.pythonhosted.org/packages/source/g/${_pyname}/${_pyname}-${pkgver}.tar.gz"
+
+builddir="$srcdir/$_pyname-$pkgver"
+
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="da9d280f2ab3f9d99e2f011d56d94b09a12e85a5a1e9f78933a93cc57c7778d9002e1a023552a2611283da696334ba795cd7e8003b311db05e9b6b40aca34dc7 google-auth-httplib2-0.0.3.tar.gz"