aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-04-05 15:26:15 +0000
committerTimothy Legge <timlegge@gmail.com>2020-04-06 10:40:41 +0000
commitd4653d8a502cba2da11d0017e5864082e409682d (patch)
tree7db939d3ac96747f4dbb7a53f93727192e4e6518
parent34423baf58676c83bf0505b795f7e33d89bd4063 (diff)
downloadaports-d4653d8a502cba2da11d0017e5864082e409682d.tar.bz2
aports-d4653d8a502cba2da11d0017e5864082e409682d.tar.xz
community/perl-class-load-xs: modernize APKBUILD
-rw-r--r--community/perl-class-load-xs/APKBUILD35
1 files changed, 14 insertions, 21 deletions
diff --git a/community/perl-class-load-xs/APKBUILD b/community/perl-class-load-xs/APKBUILD
index 89a89e3e8c..1ebd38e14d 100644
--- a/community/perl-class-load-xs/APKBUILD
+++ b/community/perl-class-load-xs/APKBUILD
@@ -1,41 +1,34 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-class-load-xs
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Class-Load-XS
pkgver=0.10
-pkgrel=4
+pkgrel=5
pkgdesc="XS implementation of parts of Class::Load"
url="https://metacpan.org/release/Class-Load-XS/"
arch="all"
license="Artistic-2.0"
-cpandepends="perl-class-load"
-cpanmakedepends="perl-test-requires perl-test-fatal perl-module-implementation perl-test-needs"
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+depends="perl perl-class-load"
+makedepends="perl-dev"
+checkdepends="perl-test-without-module perl-test-requires perl-test-needs perl-test-fatal perl-module-implementation"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/E/ET/ETHER/$_pkgreal-$pkgver.tar.gz"
-
+source="https://cpan.metacpan.org/authors/id/E/ET/ETHER/Class-Load-XS-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-check() {
- cd "$builddir"
- make test
-}
-prepare() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}