aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-05-05 02:43:44 -0300
committerRasmus Thomsen <oss@cogitri.dev>2020-05-05 08:11:03 +0000
commite68de1640eb658512921a4b479b35fc632cc123a (patch)
treead8e6f1c306c46a7b0798234e68497922ac67c3c
parent729d2d726606c2a7dda88d992dd83933a8df4f5f (diff)
downloadaports-e68de1640eb658512921a4b479b35fc632cc123a.tar.bz2
aports-e68de1640eb658512921a4b479b35fc632cc123a.tar.xz
testing/cloudflare-ddns: new aport
https://github.com/ailionx/cloudflare-ddns DDNS script to sync public IP address to CloudFlare dns records
-rw-r--r--testing/cloudflare-ddns/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/testing/cloudflare-ddns/APKBUILD b/testing/cloudflare-ddns/APKBUILD
new file mode 100644
index 0000000000..4c571f7d51
--- /dev/null
+++ b/testing/cloudflare-ddns/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=cloudflare-ddns
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="DDNS script to sync public IP address to CloudFlare dns records"
+options="!check" # No testsuite
+url="https://github.com/ailionx/cloudflare-ddns"
+arch="noarch"
+license="MIT"
+depends="py3-setuptools py3-requests"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ailionx/cloudflare-ddns/archive/$pkgver.tar.gz"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="b059b7795bb26de2c83e3619a5dba281bfacbbf0fa33a5678846043d64f805b8f40c3266e246f1dfd36003205babed4938a039f9f669aabedf9903ca0360a867 cloudflare-ddns-1.3.0.tar.gz"