aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarlus Saraiva <marlus.saraiva@gmail.com>2015-07-28 01:56:38 +0200
committerFrancesco Colista <fcolista@alpinelinux.org>2015-07-28 09:18:00 +0000
commitf3890defb7eb96e6fd502cf37d4fbc79bdb8fea1 (patch)
tree43002e5b47b16941bd9c54151a71bac13c22e1c1
parentdb593b70af9c24b02ca924678c8fd64dd0f8bc08 (diff)
downloadaports-f3890defb7eb96e6fd502cf37d4fbc79bdb8fea1.tar.bz2
aports-f3890defb7eb96e6fd502cf37d4fbc79bdb8fea1.tar.xz
main/elixir: move from testing
-rw-r--r--main/elixir/APKBUILD (renamed from testing/elixir/APKBUILD)0
-rw-r--r--testing/elixir/fix_system_cmd_test.patch20
2 files changed, 0 insertions, 20 deletions
diff --git a/testing/elixir/APKBUILD b/main/elixir/APKBUILD
index c4d6db0b1a..c4d6db0b1a 100644
--- a/testing/elixir/APKBUILD
+++ b/main/elixir/APKBUILD
diff --git a/testing/elixir/fix_system_cmd_test.patch b/testing/elixir/fix_system_cmd_test.patch
deleted file mode 100644
index be852a5ce8..0000000000
--- a/testing/elixir/fix_system_cmd_test.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./lib/elixir/test/elixir/system_test.exs.orig
-+++ ./lib/elixir/test/elixir/system_test.exs
-@@ -63,7 +63,7 @@ defmodule SystemTest do
- assert {"hello\n", 0} = System.cmd "echo", ["hello"]
-
- opts = [into: [], cd: System.cwd!, env: %{"foo" => "bar"},
-- arg0: "hecho", stderr_to_stdout: true, parallelism: true]
-+ arg0: "echo", stderr_to_stdout: true, parallelism: true]
- assert {["hello\n"], 0} = System.cmd "echo", ["hello"], opts
-
- with_tmp_dir(fn dir ->
-@@ -73,7 +73,7 @@ defmodule SystemTest do
-
- File.cd!(dir)
- assert :enoent = catch_error(System.cmd("echo2", ["hello"]))
-- assert {"hello\n", 0} = System.cmd(Path.join([System.cwd, "echo2"]), ["hello"])
-+ assert {"hello\n", 0} = System.cmd(Path.join([System.cwd, "echo2"]), ["hello"], [{:arg0, "echo"}])
- end)
- end
-