aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-12-23 00:05:27 +0100
committerRasmus Thomsen <oss@cogitri.dev>2019-12-23 00:05:27 +0100
commitfbd444c6b36f470e59435de6b1028d5b6ff1a83b (patch)
tree64262636cecce470a6cfcd0e85a09c5672be319b
parent30e766a91610b8f8d7617eb6b41ec844add35733 (diff)
downloadaports-fbd444c6b36f470e59435de6b1028d5b6ff1a83b.tar.bz2
aports-fbd444c6b36f470e59435de6b1028d5b6ff1a83b.tar.xz
community/tomcat-native: fix lints
-rw-r--r--community/tomcat-native/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/community/tomcat-native/APKBUILD b/community/tomcat-native/APKBUILD
index ffc8fbbf1e..1a0870967d 100644
--- a/community/tomcat-native/APKBUILD
+++ b/community/tomcat-native/APKBUILD
@@ -10,12 +10,10 @@ license="Apache-2.0"
options="!check" # package has no tests
makedepends="apr-dev chrpath openjdk8 openssl-dev"
subpackages="$pkgname-dev"
-source="https://www-eu.apache.org/dist/tomcat/tomcat-connectors/native/$pkgver/source/$pkgname-$pkgver-src.tar.gz"
+source="https://www-eu.apache.org/dist/tomcat/tomcat-connectors/native/$pkgver/source/tomcat-native-$pkgver-src.tar.gz"
builddir="$srcdir/$pkgname-$pkgver-src/native"
build() {
- cd "$builddir"
-
./configure --prefix=/usr \
--with-apr=/usr/bin/apr-1-config \
--with-java-home=/usr/lib/jvm/default-jvm \
@@ -24,8 +22,6 @@ build() {
}
package() {
- cd "$builddir"
-
make DESTDIR="$pkgdir" install
# Remove redundant rpath.
@@ -35,7 +31,7 @@ package() {
rmdir "$pkgdir"/usr/bin
}
-dev() {
+dev() {
default_dev
mv "$subpkgdir"/usr/lib/libtcnative-1.so "$pkgdir"/usr/lib/
}