aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-11-12 13:51:47 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-12 10:48:38 -0300
commitfd50f98d4fade9978e6d7815485a93b5231a2c69 (patch)
treeee62845083af18f48093a409144adf3adc85a23a
parentb73b1e51f320e8763a715c4c38e9d07ab2ddcd63 (diff)
downloadaports-fd50f98d4fade9978e6d7815485a93b5231a2c69.tar.bz2
aports-fd50f98d4fade9978e6d7815485a93b5231a2c69.tar.xz
community/kio-extras: move from testing
-rw-r--r--community/kio-extras/APKBUILD (renamed from testing/kio-extras/APKBUILD)13
1 files changed, 11 insertions, 2 deletions
diff --git a/testing/kio-extras/APKBUILD b/community/kio-extras/APKBUILD
index d209da5806..d9a0795cfd 100644
--- a/testing/kio-extras/APKBUILD
+++ b/community/kio-extras/APKBUILD
@@ -10,12 +10,19 @@ license="GPL-2.0-or-later (LGPL-2.1-only OR LGPL-3.0-only)"
depends="kinit"
makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev karchive-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kdbusaddons-dev kdoctools-dev kdnssd-dev kiconthemes-dev ki18n-dev kio-dev solid-dev kbookmarks-dev kguiaddons-dev syntax-highlighting-dev kpty-dev kactivities-dev phonon-dev samba-dev libssh-dev libmtp-dev gperf khtml-dev shared-mime-info nfs-utils-dev"
checkdepends="xvfb-run kinit"
-source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+source="https://download.kde.org/stable/applications/$pkgver/src/kio-extras-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
options="!check" # Requires running dbus-server
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -23,10 +30,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}